summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/xfs-sources')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog8
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20-r12
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.20-r1.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 13efbae3fa98..78dd56be0b35 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.21 2003/03/16 22:39:54 livewire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.22 2003/03/18 03:26:20 livewire Exp $
+*xfs-sources-2.4.20-r1 (17 March 2003)
+
+ 17 March 2003; Bob Johnson <livewire@gentoo.org>
+
+ - added 3/16/2003 XFS snapshot
+
*xfs-sources-2.4.20 (16 March 2003)
16 March 2003; Bob Johnson <livewire@gentoo.org>
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20-r1 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20-r1
new file mode 100644
index 000000000000..2693ae828287
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20-r1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 7805a6fda090743d995e1f679dfc3058 patches-2.4.20-xfs.tar.bz2 3012141
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.20-r1.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.20-r1.ebuild
new file mode 100644
index 000000000000..afdd25354e96
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.20-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.20-r1.ebuild,v 1.1 2003/03/18 03:26:20 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-${P/-sources-2.4.20}
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}