summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pvfs2/ChangeLog8
-rw-r--r--sys-cluster/pvfs2/files/pvfs2-super.c.patch50
-rw-r--r--sys-cluster/pvfs2/pvfs2-2.7.1.ebuild9
3 files changed, 62 insertions, 5 deletions
diff --git a/sys-cluster/pvfs2/ChangeLog b/sys-cluster/pvfs2/ChangeLog
index d220bd85c549..4276a1cc93fc 100644
--- a/sys-cluster/pvfs2/ChangeLog
+++ b/sys-cluster/pvfs2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/pvfs2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvfs2/ChangeLog,v 1.17 2008/07/28 20:51:16 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvfs2/ChangeLog,v 1.18 2008/09/04 02:22:12 nerdboy Exp $
+
+ 04 Sep 2008; Steve Arnold <nerdboy@gentoo.org> +files/pvfs2-super.c.patch,
+ pvfs2-2.7.1.ebuild:
+ Updated with upstream patch for kernel 2.6.26 incompatible pointer type -
+ http://www.beowulf-underground.org/pipermail/pvfs2-users/2008-July/002506.html
+ Also disabled experimental threaded kmod helper.
28 Jul 2008; Panagiotis Christopoulos <pchrist@gentoo.org> metadata.xml:
Update metadata.xml to include USE flag descriptions. Entries taken from
diff --git a/sys-cluster/pvfs2/files/pvfs2-super.c.patch b/sys-cluster/pvfs2/files/pvfs2-super.c.patch
new file mode 100644
index 000000000000..342813b769be
--- /dev/null
+++ b/sys-cluster/pvfs2/files/pvfs2-super.c.patch
@@ -0,0 +1,50 @@
+Index: src/kernel/linux-2.6/super.c
+===================================================================
+RCS file: /projects/cvsroot/pvfs2/src/kernel/linux-2.6/super.c,v
+retrieving revision 1.102
+diff -a -u -r1.102 super.c
+--- src/kernel/linux-2.6/super.c 10 Jun 2008 14:35:23 -0000 1.102
++++ src/kernel/linux-2.6/super.c 23 Jul 2008 18:14:20 -0000
+@@ -7,6 +7,7 @@
+ #include "pvfs2-kernel.h"
+ #include "pvfs2-bufmap.h"
+ #include "pvfs2-internal.h"
++#include "linux/version.h"
+
+ /* list for storing pvfs2 specific superblocks in use */
+ LIST_HEAD(pvfs2_superblocks);
+@@ -320,6 +321,7 @@
+
+ #endif /* PVFS2_LINUX_KERNEL_2_4 */
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,26)
+ /* called when the VFS removes this inode from the inode cache */
+ static void pvfs2_put_inode(
+ struct inode *inode)
+@@ -349,6 +351,7 @@
+ #endif
+ }
+ }
++#endif
+
+ #ifdef HAVE_STATFS_LITE_SUPER_OPERATIONS
+ static int pvfs2_statfs_lite(
+@@ -852,14 +855,18 @@
+ clear_inode: pvfs2_clear_inode,
+ put_inode: pvfs2_put_inode,
+ #else
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,26)
+ .drop_inode = generic_delete_inode,
++#endif
+ .alloc_inode = pvfs2_alloc_inode,
+ .destroy_inode = pvfs2_destroy_inode,
+ #ifdef HAVE_READ_INODE
+ .read_inode = pvfs2_read_inode,
+ #endif
+ .dirty_inode = pvfs2_dirty_inode,
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,26)
+ .put_inode = pvfs2_put_inode,
++#endif
+ .statfs = pvfs2_statfs,
+ .remount_fs = pvfs2_remount,
+ #ifdef HAVE_FIND_INODE_HANDLE_SUPER_OPERATIONS \ No newline at end of file
diff --git a/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild b/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild
index 4fef26d64ae1..4cdf15c7f1a6 100644
--- a/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild
+++ b/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild,v 1.4 2008/05/29 00:24:45 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild,v 1.5 2008/09/04 02:22:12 nerdboy Exp $
-inherit linux-mod autotools toolchain-funcs
+inherit linux-mod toolchain-funcs
MY_PN="${PN%[0-9]*}"
MY_P="${MY_PN}-${PV}"
@@ -11,7 +11,7 @@ S="${WORKDIR}/${MY_P}"
DESCRIPTION="Parallel Virtual File System version 2"
HOMEPAGE="http://www.pvfs.org/"
SRC_URI="ftp://ftp.parl.clemson.edu/pub/pvfs2/${MY_P}.tar.gz"
-IUSE="gtk server static doc ssl examples apidocs threads"
+IUSE="apidocs doc examples gtk server ssl static"
RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
ssl? ( dev-libs/openssl )
sys-libs/db"
@@ -44,7 +44,6 @@ pkg_setup() {
$(use_enable static static-server)
$(use_enable gtk karma)
$(use_enable server)
- $(use_enable threads threaded-kmod-helper)
$(use_with ssl openssl /usr/$(get_libdir))"
}
@@ -60,6 +59,8 @@ src_unpack() {
# Support for >=linux-2.6.25, should be unnecessary next release.
sed -i 's/ Q=@echo >.*/ Q=@/' src/kernel/linux-2.6/Makefile.in
+ # upstream patch for 2.6.26 kernels
+ epatch "${FILESDIR}"/${PN}-super.c.patch
}
src_compile() {