summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/tgt')
-rw-r--r--sys-block/tgt/ChangeLog10
-rw-r--r--sys-block/tgt/tgt-1.0.22.ebuild6
-rw-r--r--sys-block/tgt/tgt-1.0.24.ebuild60
3 files changed, 71 insertions, 5 deletions
diff --git a/sys-block/tgt/ChangeLog b/sys-block/tgt/ChangeLog
index 8d632f355057..a60ebf7e2576 100644
--- a/sys-block/tgt/ChangeLog
+++ b/sys-block/tgt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/tgt
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/ChangeLog,v 1.17 2011/12/28 11:50:24 ultrabug Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/ChangeLog,v 1.18 2012/02/04 16:54:30 alexxy Exp $
+
+*tgt-1.0.24 (04 Feb 2012)
+
+ 04 Feb 2012; Alexey Shvetsov <alexxy@gentoo.org> tgt-1.0.22.ebuild,
+ +tgt-1.0.24.ebuild:
+ Version bump =D
*tgt-1.0.22 (28 Dec 2011)
diff --git a/sys-block/tgt/tgt-1.0.22.ebuild b/sys-block/tgt/tgt-1.0.22.ebuild
index 8d12b4333655..52c79cec8093 100644
--- a/sys-block/tgt/tgt-1.0.22.ebuild
+++ b/sys-block/tgt/tgt-1.0.22.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/tgt-1.0.22.ebuild,v 1.2 2011/12/30 18:18:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/tgt-1.0.22.ebuild,v 1.3 2012/02/04 16:54:30 alexxy Exp $
EAPI=4
@@ -10,7 +10,7 @@ MY_TREE="3e216c9"
DESCRIPTION="Linux SCSI target framework (tgt)"
HOMEPAGE="http://stgt.sourceforge.net"
-SRC_URI="https://github.com/fujita/tgt/zipball/v${PV} -> ${P}.zip"
+SRC_URI="https://github.com/fujita/tgt/tarball/v${PV} -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/sys-block/tgt/tgt-1.0.24.ebuild b/sys-block/tgt/tgt-1.0.24.ebuild
new file mode 100644
index 000000000000..7ea934a217bc
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.24.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/tgt-1.0.24.ebuild,v 1.1 2012/02/04 16:54:30 alexxy Exp $
+
+EAPI=4
+
+inherit flag-o-matic linux-info
+
+MY_TREE="e039354"
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="http://stgt.sourceforge.net"
+SRC_URI="https://github.com/fujita/tgt/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ibmvio infiniband fcp fcoe"
+
+DEPEND="dev-perl/config-general
+ dev-libs/libxslt
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )"
+RDEPEND="${DEPEND}
+ sys-apps/sg3_utils"
+
+S="${WORKDIR}"/fujita-tgt-"${MY_TREE}"
+
+pkg_setup() {
+ CONFIG_CHECK="~SCSI_TGT"
+ WARNING_SCSI_TGT="Your kernel needs CONFIG_SCSI_TGT"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's:\($(CC)\):\1 $(LDFLAGS):' usr/Makefile || die "sed failed"
+
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @install: all @g" doc/Makefile || die
+}
+
+src_compile() {
+ local myconf
+ use ibmvio && myconf="${myconf} IBMVIO=1"
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use fcp && myconf="${myconf} FCP=1"
+ use fcoe && myconf="${myconf} FCOE=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF}
+ doinitd "${FILESDIR}/tgtd"
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}