summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog8
-rw-r--r--sys-apps/portage/portage-2.1.11.62.ebuild8
-rw-r--r--sys-apps/portage/portage-2.1.12.13.ebuild8
-rw-r--r--sys-apps/portage/portage-2.1.12.2.ebuild8
-rw-r--r--sys-apps/portage/portage-2.1.13.1.ebuild8
-rw-r--r--sys-apps/portage/portage-2.2.0_alpha177.ebuild8
-rw-r--r--sys-apps/portage/portage-2.2.0_alpha188.ebuild8
-rw-r--r--sys-apps/portage/portage-2.2.0_alpha190.ebuild8
-rw-r--r--sys-apps/portage/portage-9999.ebuild8
9 files changed, 39 insertions, 33 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 9184837c3e44..d420bf70c3fd 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1321 2013/07/26 21:34:51 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1322 2013/07/28 09:21:49 mgorny Exp $
+
+ 28 Jul 2013; Michał Górny <mgorny@gentoo.org> portage-2.1.11.62.ebuild,
+ portage-2.1.12.13.ebuild, portage-2.1.12.2.ebuild, portage-2.1.13.1.ebuild,
+ portage-2.2.0_alpha177.ebuild, portage-2.2.0_alpha188.ebuild,
+ portage-2.2.0_alpha190.ebuild, portage-9999.ebuild:
+ Use virtual/pypy for PyPy dep.
*portage-2.2.0_alpha190 (26 Jul 2013)
diff --git a/sys-apps/portage/portage-2.1.11.62.ebuild b/sys-apps/portage/portage-2.1.11.62.ebuild
index e6634f088fc5..d65d053b2e07 100644
--- a/sys-apps/portage/portage-2.1.11.62.ebuild
+++ b/sys-apps/portage/portage-2.1.11.62.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.62.ebuild,v 1.12 2013/07/01 02:24:59 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.62.ebuild,v 1.13 2013/07/28 09:21:49 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -30,15 +30,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )
diff --git a/sys-apps/portage/portage-2.1.12.13.ebuild b/sys-apps/portage/portage-2.1.12.13.ebuild
index 644876dd7c53..88a1cce4c50a 100644
--- a/sys-apps/portage/portage-2.1.12.13.ebuild
+++ b/sys-apps/portage/portage-2.1.12.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.12.13.ebuild,v 1.2 2013/07/10 20:41:49 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.12.13.ebuild,v 1.3 2013/07/28 09:21:49 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -30,15 +30,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )
diff --git a/sys-apps/portage/portage-2.1.12.2.ebuild b/sys-apps/portage/portage-2.1.12.2.ebuild
index a2885ad0c6d4..2d43bf50cc5d 100644
--- a/sys-apps/portage/portage-2.1.12.2.ebuild
+++ b/sys-apps/portage/portage-2.1.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.12.2.ebuild,v 1.14 2013/07/01 02:24:59 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.12.2.ebuild,v 1.15 2013/07/28 09:21:49 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -30,15 +30,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )
diff --git a/sys-apps/portage/portage-2.1.13.1.ebuild b/sys-apps/portage/portage-2.1.13.1.ebuild
index 403540016384..dce7581ec72a 100644
--- a/sys-apps/portage/portage-2.1.13.1.ebuild
+++ b/sys-apps/portage/portage-2.1.13.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.13.1.ebuild,v 1.1 2013/07/26 21:32:54 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.13.1.ebuild,v 1.2 2013/07/28 09:21:49 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -30,15 +30,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )
diff --git a/sys-apps/portage/portage-2.2.0_alpha177.ebuild b/sys-apps/portage/portage-2.2.0_alpha177.ebuild
index b98ff705ab0a..8754b5b94844 100644
--- a/sys-apps/portage/portage-2.2.0_alpha177.ebuild
+++ b/sys-apps/portage/portage-2.2.0_alpha177.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha177.ebuild,v 1.3 2013/07/01 02:24:59 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha177.ebuild,v 1.4 2013/07/28 09:21:49 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -30,15 +30,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )
diff --git a/sys-apps/portage/portage-2.2.0_alpha188.ebuild b/sys-apps/portage/portage-2.2.0_alpha188.ebuild
index df66472707f7..2430690afee9 100644
--- a/sys-apps/portage/portage-2.2.0_alpha188.ebuild
+++ b/sys-apps/portage/portage-2.2.0_alpha188.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha188.ebuild,v 1.2 2013/07/10 20:41:49 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha188.ebuild,v 1.3 2013/07/28 09:21:49 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -30,15 +30,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )
diff --git a/sys-apps/portage/portage-2.2.0_alpha190.ebuild b/sys-apps/portage/portage-2.2.0_alpha190.ebuild
index f9f8d72937c6..d9276f11a0eb 100644
--- a/sys-apps/portage/portage-2.2.0_alpha190.ebuild
+++ b/sys-apps/portage/portage-2.2.0_alpha190.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha190.ebuild,v 1.1 2013/07/26 21:34:51 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha190.ebuild,v 1.2 2013/07/28 09:21:49 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -30,15 +30,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index 3ad9bbc44c48..fb9776e28d88 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.86 2013/07/26 20:07:49 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.87 2013/07/28 09:21:49 mgorny Exp $
EAPI=3
PYTHON_COMPAT=(
@@ -28,15 +28,15 @@ python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
!pypy2_0? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( dev-python/pypy:2.0[bzip2,ssl] ) ) )
+ pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
- python_targets_pypy1_9? ( dev-python/pypy:1.9 )
- python_targets_pypy2_0? ( dev-python/pypy:2.0 )
+ python_targets_pypy1_9? ( virtual/pypy:1.9 )
+ python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
python_targets_python3_1? ( dev-lang/python:3.1 )