summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/texinfo/texinfo-4.13.ebuild')
-rw-r--r--sys-apps/texinfo/texinfo-4.13.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/texinfo/texinfo-4.13.ebuild b/sys-apps/texinfo/texinfo-4.13.ebuild
index c4a0521d07fb..9ac784b5065a 100644
--- a/sys-apps/texinfo/texinfo-4.13.ebuild
+++ b/sys-apps/texinfo/texinfo-4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.13.ebuild,v 1.6 2009/02/22 14:38:04 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.13.ebuild,v 1.7 2009/02/24 07:59:12 kumba Exp $
inherit flag-o-matic
@@ -23,6 +23,12 @@ DEPEND="${RDEPEND}
src_compile() {
use static && append-ldflags -static
econf $(use_enable nls) || die
+
+ # Make cross-compiler safe (#196041)
+ if tc-is-cross-compiler; then
+ emake -C tools/gnulib/lib || die "emake -C tools/gnulib/lib"
+ fi
+
emake || die "emake"
}