summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/nbd')
-rw-r--r--sys-apps/nbd/ChangeLog11
-rw-r--r--sys-apps/nbd/files/digest-nbd-141
-rw-r--r--sys-apps/nbd/nbd-14.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/nbd/ChangeLog b/sys-apps/nbd/ChangeLog
new file mode 100644
index 000000000000..9bcfd00be732
--- /dev/null
+++ b/sys-apps/nbd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/nbd
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/nbd/ChangeLog,v 1.1 2002/02/19 00:48:34 chouser Exp $
+
+*nbd-14 (18 Feb 2002)
+
+ 18 Feb 2002; Chris Houser <chouser@gentoo.org> :
+
+ This is the first ebuild for nbd, the Linux Network Block Device client and
+ server userland utilities. To use these, you will need to have NBD compiled
+ into your kernel.
diff --git a/sys-apps/nbd/files/digest-nbd-14 b/sys-apps/nbd/files/digest-nbd-14
new file mode 100644
index 000000000000..5aadb3d59a50
--- /dev/null
+++ b/sys-apps/nbd/files/digest-nbd-14
@@ -0,0 +1 @@
+MD5 a049cf102d0649caaeb50cb45fae85a4 nbd.14.tar.gz 127623
diff --git a/sys-apps/nbd/nbd-14.ebuild b/sys-apps/nbd/nbd-14.ebuild
new file mode 100644
index 000000000000..ea8167179287
--- /dev/null
+++ b/sys-apps/nbd/nbd-14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Chris Houser <chouser@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/nbd/nbd-14.ebuild,v 1.1 2002/02/19 00:48:34 chouser Exp $
+
+P=${P//-/.}
+S=${WORKDIR}/${PN}
+DESCRIPTION="Userland client/server for kernel network block device"
+SRC_URI="http://atrey.karlin.mff.cuni.cz/~pavel/nbd/${P}.tar.gz"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~pavel/nbd/nbd.html"
+
+DEPEND=">=sys-devel/gcc-2.95.3
+ >=sys-devel/make-3.79.1"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ mkdir -p ${D}/usr/bin
+ make \
+ prefix=${D}/usr \
+ install || die "make install failed"
+}