summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/htop')
-rw-r--r--sys-apps/htop/ChangeLog5
-rw-r--r--sys-apps/htop/Manifest6
-rw-r--r--sys-apps/htop/htop-0.3.1.ebuild10
3 files changed, 14 insertions, 7 deletions
diff --git a/sys-apps/htop/ChangeLog b/sys-apps/htop/ChangeLog
index 78b370b0cdbc..3c72c25dc62d 100644
--- a/sys-apps/htop/ChangeLog
+++ b/sys-apps/htop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/htop
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/htop/ChangeLog,v 1.3 2004/06/03 15:58:15 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/htop/ChangeLog,v 1.4 2004/06/10 09:15:51 wschlich Exp $
+
+ 10 Jun 2004; Wolfram Schlich <wschlich@gentoo.org> htop-0.3.1.ebuild:
+ added debug options
03 Jun 2004; David Holm <dholm@gentoo.org> htop-0.3.1.ebuild:
Added to ~ppc.
diff --git a/sys-apps/htop/Manifest b/sys-apps/htop/Manifest
index ad5bc3d9cfbe..52e1f5d93ff8 100644
--- a/sys-apps/htop/Manifest
+++ b/sys-apps/htop/Manifest
@@ -1,6 +1,6 @@
-MD5 0c05e15ed15a5d47b34455c6e7f31836 ChangeLog 490
-MD5 ce433d9edceef9e3225f605121ec61fd htop-0.3.ebuild 670
MD5 eb4bbf8601e9cc359a1f91d669379c1a metadata.xml 568
-MD5 a8a1dc3249dd7c1c63f87c0d9bf4f295 htop-0.3.1.ebuild 674
+MD5 ce433d9edceef9e3225f605121ec61fd htop-0.3.ebuild 670
+MD5 e37dd8c84189e942cd7b713e0d1c388e ChangeLog 584
+MD5 1fc35581ba700a52601838ddc5621e30 htop-0.3.1.ebuild 775
MD5 8123f72d136ab55139efee23411e3ab6 files/digest-htop-0.3 59
MD5 47f1850a95a3c5c1447a7606ca9ff1ad files/digest-htop-0.3.1 61
diff --git a/sys-apps/htop/htop-0.3.1.ebuild b/sys-apps/htop/htop-0.3.1.ebuild
index 3452b1df9845..0ae7579c544c 100644
--- a/sys-apps/htop/htop-0.3.1.ebuild
+++ b/sys-apps/htop/htop-0.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/htop/htop-0.3.1.ebuild,v 1.3 2004/06/03 15:58:15 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/htop/htop-0.3.1.ebuild,v 1.4 2004/06/10 09:15:51 wschlich Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="interactive process viewer"
HOMEPAGE="http://htop.sourceforge.net"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE=""
+IUSE="debug"
DEPEND="sys-libs/ncurses"
src_unpack() {
@@ -19,6 +19,10 @@ src_unpack() {
}
src_compile() {
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
econf || die "configure failed"
emake || die "make failed"
}