summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/files/digest-mathomatic-12.6.43
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index f35e7a5388b9..19eacea40004 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.14 2006/07/15 22:09:53 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.15 2006/10/06 18:43:22 cryos Exp $
+
+*mathomatic-12.6.4 (06 Oct 2006)
+
+ 06 Oct 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +mathomatic-12.6.4.ebuild:
+ Version bump.
*mathomatic-12.5.20 (15 Jul 2006)
diff --git a/sci-mathematics/mathomatic/files/digest-mathomatic-12.6.4 b/sci-mathematics/mathomatic/files/digest-mathomatic-12.6.4
new file mode 100644
index 000000000000..b0319b754f11
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/digest-mathomatic-12.6.4
@@ -0,0 +1,3 @@
+MD5 e81c5a72451608407575e3c41ec99666 mathomatic-12.6.4.tar.bz2 116782
+RMD160 5d551c269423c3cf50d29ee9c4b4b8b02f98bb2d mathomatic-12.6.4.tar.bz2 116782
+SHA256 9ee5d6b1aeef1b77002bc4069b8af9a3a9e3fdd9bbe4ecd57b8df953e156c93f mathomatic-12.6.4.tar.bz2 116782
diff --git a/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild b/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild
new file mode 100644
index 000000000000..6c2f5a2790f5
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.6.4.ebuild,v 1.1 2006/10/06 18:43:22 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc icc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ icc? ( dev-lang/icc )"
+
+src_compile() {
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake READLINE=1 || die "emake failed"
+ else
+ emake READLINE=1 || die "emake failed"
+ fi
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic
+ dodoc changes.txt README.txt
+ doman mathomatic.1
+
+ if use doc; then
+ dohtml doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*.in
+ fi
+}