summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/ChangeLog8
-rw-r--r--sci-astronomy/wcslib/files/wcslib-4.4.4-ldflags.patch13
-rw-r--r--sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild50
3 files changed, 70 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index 68e526d45fbc..9d78d333ff3b 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.9 2010/01/29 03:04:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.10 2010/05/22 07:30:37 jlec Exp $
+
+*wcslib-4.4.4-r1 (22 May 2010)
+
+ 22 May 2010; Justin Lecher <jlec@gentoo.org>
+ +wcslib-4.4.4-r1.ebuild, +files/wcslib-4.4.4-ldflags.patch:
+ LDFLAGS respected
*wcslib-4.4.4 (29 Jan 2010)
diff --git a/sci-astronomy/wcslib/files/wcslib-4.4.4-ldflags.patch b/sci-astronomy/wcslib/files/wcslib-4.4.4-ldflags.patch
new file mode 100644
index 000000000000..f227bb8b8841
--- /dev/null
+++ b/sci-astronomy/wcslib/files/wcslib-4.4.4-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Fortran/GNUmakefile b/Fortran/GNUmakefile
+index 6a9600d..94c33a3 100644
+--- a/Fortran/GNUmakefile
++++ b/Fortran/GNUmakefile
+@@ -169,7 +169,7 @@ $(SHRLIB) : $(PICLIB)
+ mkdir tmp
+ cd tmp && \
+ $(AR) x ../$(PICLIB) && \
+- $(SHRLD) -o $(@F) *.o && \
++ $(SHRLD) $(LDFLAGS) -o $(@F) *.o && \
+ mv $(@F) ../../C
+ - $(RM) -r tmp
+
diff --git a/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild b/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild
new file mode 100644
index 000000000000..f2a4110b3cd3
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild,v 1.1 2010/05/22 07:30:37 jlec Exp $
+
+EAPI=2
+inherit eutils virtualx flag-o-matic
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ sci-libs/cfitsio
+ sci-libs/pgplot"
+DEPEND="${RDEPEND}
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.4.2-flibs.patch
+ epatch "${FILESDIR}"/${PN}-4.4.4-destdir.patch
+ epatch "${FILESDIR}"/${PN}-4.4.4-ldflags.patch
+ append-flags -U_FORTIFY_SOURCE
+}
+
+src_compile() {
+ # -j1 forced. build system too crappy to be worth debugging
+ # does not really fix anything
+ emake -j1 || die "emake failed"
+}
+
+src_test() {
+ Xemake check || die "emake test failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r *.pdf html || die
+ fi
+}