summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zope')
-rw-r--r--net-zope/zope/ChangeLog9
-rw-r--r--net-zope/zope/files/digest-zope-2.9.53
-rw-r--r--net-zope/zope/files/digest-zope-3.2.23
-rw-r--r--net-zope/zope/zope-2.9.5.ebuild83
-rw-r--r--net-zope/zope/zope-3.2.2.ebuild124
5 files changed, 221 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index d13cf008b4b1..c40fad5e65c6 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.113 2006/09/03 15:39:30 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.114 2006/10/02 16:27:21 radek Exp $
+
+*zope-3.2.2 (02 Oct 2006)
+*zope-2.9.5 (02 Oct 2006)
+
+ 02 Oct 2006; Radoslaw Stachowiak <radek@gentoo.org> +zope-2.9.5.ebuild,
+ +zope-3.2.2.ebuild:
+ version bump
03 Sep 2006; Thomas Cort <tcort@gentoo.org> zope-2.7.9.ebuild,
zope-2.8.8.ebuild:
diff --git a/net-zope/zope/files/digest-zope-2.9.5 b/net-zope/zope/files/digest-zope-2.9.5
new file mode 100644
index 000000000000..19a2b06233fb
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.9.5
@@ -0,0 +1,3 @@
+MD5 b648770c9e3735f88b61b56384942ff8 Zope-2.9.5-final.tgz 6982114
+RMD160 d8e26839618a19fbb6528967c3d8fc0266251a7d Zope-2.9.5-final.tgz 6982114
+SHA256 e4036fa61af22379530b1a42534591d7f19fdbcb3345d20e7a337b3c375a323e Zope-2.9.5-final.tgz 6982114
diff --git a/net-zope/zope/files/digest-zope-3.2.2 b/net-zope/zope/files/digest-zope-3.2.2
new file mode 100644
index 000000000000..cfac01d13bac
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-3.2.2
@@ -0,0 +1,3 @@
+MD5 c9413e061ffde6ac8b57e5c9b528815c Zope-3.2.2.tgz 6544087
+RMD160 1e7e08e1178f449bf120d7fc2caa6259fde1a0cf Zope-3.2.2.tgz 6544087
+SHA256 c6f6d49d8b910bc35a32b848c6296b7ad61cb64f83974b52dd3623169f141ba4 Zope-3.2.2.tgz 6544087
diff --git a/net-zope/zope/zope-2.9.5.ebuild b/net-zope/zope/zope-2.9.5.ebuild
new file mode 100644
index 000000000000..82c166574816
--- /dev/null
+++ b/net-zope/zope/zope-2.9.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.5.ebuild,v 1.1 2006/10/02 16:27:21 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR} || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+
+ epatch ${FILESDIR}/2.9/${P}_logerror.patch
+ pwd
+ sleep 15
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}
diff --git a/net-zope/zope/zope-3.2.2.ebuild b/net-zope/zope/zope-3.2.2.ebuild
new file mode 100644
index 000000000000..0acb4b2d4943
--- /dev/null
+++ b/net-zope/zope/zope-3.2.2.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-3.2.2.ebuild,v 1.1 2006/10/02 16:27:21 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.0
+ >=sys-apps/sed-4.0.5"
+
+S=${WORKDIR}/Zope-${PV}
+
+ZUNAME=zope
+ZGNAME=zope
+
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+ZSKELDIR=${ZSERVDIR}/zopeskel
+ZINSTDIR=/var/lib/zope/${P}
+
+src_compile() {
+
+ cd ${S}
+
+ ./configure --prefix=${D}${ZSERVDIR} --with-python=/usr/bin/python2.4 || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+
+ cd ${S}
+
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ for DIR in schema security skins style zcml zsync
+ do
+ docinto ${DIR}
+ dodoc Zope/doc/${DIR}/*
+ done
+
+ make install prefix=${D}${ZSERVDIR}
+
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to zopeskel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}${ZSKELDIR}/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGNAME} 261
+ usermod -g ${ZGNAME} -c "Zope Admin User" -d /var/lib/zope -s /bin/bash ${ZUNAME} 2>&1 >/dev/null || \
+ enewuser ${ZUNAME} 261 /bin/bash /var/lib/zope ${ZGNAME} -c "Zope Admin User"
+
+ einfo "This release can create a default instance using the command: "
+ einfo " emerge --config =${PF}"
+ einfo "Instance (${P}) will be created in ${ZINSTDIR} as its home."
+ einfo "System uid/gid for instance will be: ${ZUNAME}:${ZGNAME}"
+}
+
+pkg_prerm() {
+
+ find ${ZSERVDIR}/lib/python -name \*.py[co] -exec rm -f {} \;
+}
+
+pkg_postrm() {
+
+ rmdir /usr/$(get_libdir)/${ZSERVDIR} 2>/dev/null
+ ewarn "Instances created for this package are NOT automaticaly deleted!"
+ ewarn "Inspect these locations and manually remove them (if needed):"
+ ewarn " /etc/init.d/${P}"
+ ewarn " ${ZINSTDIR}"
+}
+
+pkg_config() {
+
+ if [ -f /etc/init.d/${P} -o -d ${ZINSTDIR} ]
+ then
+ ewarn "Default instance already exists, aborting.."
+ ewarn "Please delete first /etc/init.d/${P} and ${ZINSTDIR}"
+ die "Failed to create default instance."
+ fi
+
+ mkdir -p ${ZINSTDIR}
+ einfo "Instance ${P} creation, calling mkzopeinstance.."
+ ${ZSERVDIR}/bin/mkzopeinstance --non-interactive -d ${ZINSTDIR} -u admin:admin
+
+ # bug in zope
+ einfo "Patching ${ZINSTDIR}/etc/zdaemon.conf"
+ sed -i -e 's|daemon on|daemon on\n\n # socket has to be defined inside of instance\n socket-name $INSTANCE/var/zdsock|' ${ZINSTDIR}/etc/zdaemon.conf
+
+ # remove unnecessary zope.initd
+ rm -f ${ZINSTDIR}/zope.initd
+
+ # log symlink
+ rm -rf ${ZINSTDIR}/log
+ mkdir -p /var/log/zope/${PN}
+ ln -s /var/log/zope/${PN} ${ZINSTDIR}/log
+
+ # permissions changes
+ chmod go-rwx -R ${ZINSTDIR}
+ chown ${ZUNAME}:${ZGNAME} -R ${ZINSTDIR} /var/log/zope/${PN}
+
+ cp ${ZSKELDIR}/zope.initd /etc/init.d/${P}
+ chmod 755 /etc/init.d/${P}
+ sed -i -e "s|INSTANCE_HOME|${ZINSTDIR}|" /etc/init.d/${P}
+ sed -i -e "s|zopectl|zopectl -u ${ZUNAME}|" /etc/init.d/${P}
+
+ einfo "Default instance created at ${ZINSTDIR}"
+ einfo "Created default zope user 'admin' with password 'admin'."
+ einfo "System uid/gid for instance is: ${ZUNAME}:${ZGNAME}."
+ einfo "To start instance (default ports 8080,8021) use: /etc/init.d/${P} start"
+ einfo "To start instance on every restart use: rc-update -a ${P} default"
+}