summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/persistence')
-rw-r--r--net-zope/persistence/persistence-2.13.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/net-zope/persistence/persistence-2.13.1.ebuild b/net-zope/persistence/persistence-2.13.1.ebuild
deleted file mode 100644
index 11cc21c6a768..000000000000
--- a/net-zope/persistence/persistence-2.13.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/persistence/persistence-2.13.1.ebuild,v 1.1 2010/05/30 19:39:08 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Persistence"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Persistent ExtensionClass"
-HOMEPAGE="http://pypi.python.org/pypi/Persistence"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-RDEPEND="net-zope/extensionclass
- net-zope/zodb"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="${MY_PN}"
-
-distutils_src_test_pre_hook() {
- local module
- for module in Persistence; do
- ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
- done
-}
-
-src_install() {
- distutils_src_install
- python_clean_installation_image
-}