summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_auth_external')
-rw-r--r--net-www/mod_auth_external/ChangeLog7
-rw-r--r--net-www/mod_auth_external/Manifest2
-rw-r--r--net-www/mod_auth_external/files/digest-mod_auth_external-2.2.71
-rw-r--r--net-www/mod_auth_external/mod_auth_external-2.2.7.ebuild54
4 files changed, 63 insertions, 1 deletions
diff --git a/net-www/mod_auth_external/ChangeLog b/net-www/mod_auth_external/ChangeLog
index 975fbfe27381..27c93c5f3e49 100644
--- a/net-www/mod_auth_external/ChangeLog
+++ b/net-www/mod_auth_external/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_auth_external
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_external/ChangeLog,v 1.5 2004/03/31 14:08:40 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_external/ChangeLog,v 1.6 2004/05/07 12:48:23 zul Exp $
+
+*mod_auth_external-2.2.7 (08 May 2004)
+
+ 08 May 2004; Chuck Short <zul@gentoo.org> mod_auth_external-2.2.7.ebuild:
+ Version bump, helps close #48559.
31 Mar 2004; Chuck Short <zul@gentoo.org> metadata.xml,
files/10_mod_auth_external.conf:
diff --git a/net-www/mod_auth_external/Manifest b/net-www/mod_auth_external/Manifest
index 56ee8e78a03f..ba5d28000b35 100644
--- a/net-www/mod_auth_external/Manifest
+++ b/net-www/mod_auth_external/Manifest
@@ -1,6 +1,8 @@
MD5 90758271a66ca08f46bdb145ae3fd0a7 mod_auth_external-2.2.3.ebuild 1695
+MD5 798f83c3f827c19b4ac0fd759c29d007 mod_auth_external-2.2.7.ebuild 1765
MD5 45487c5faab0760e2d2eb7055b2bddc9 ChangeLog 821
MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
MD5 a877f74ba95c1388341792c72687402b files/digest-mod_auth_external-2.2.3 156
+MD5 0682340a42fcdf3d43f063ef6174bdcc files/digest-mod_auth_external-2.2.7 74
MD5 dcccde2ac96e98d941240a2dc8c83120 files/10_mod_auth_external.conf 1240
MD5 d0cb338160e3be8790524af8071cc4df files/pwauth.pam 380
diff --git a/net-www/mod_auth_external/files/digest-mod_auth_external-2.2.7 b/net-www/mod_auth_external/files/digest-mod_auth_external-2.2.7
new file mode 100644
index 000000000000..7d5505412c5f
--- /dev/null
+++ b/net-www/mod_auth_external/files/digest-mod_auth_external-2.2.7
@@ -0,0 +1 @@
+MD5 ddd6cd5cc772f1952d83f2b8e5d91243 mod_auth_external-2.2.7.tar.gz 64220
diff --git a/net-www/mod_auth_external/mod_auth_external-2.2.7.ebuild b/net-www/mod_auth_external/mod_auth_external-2.2.7.ebuild
new file mode 100644
index 000000000000..a689656d5711
--- /dev/null
+++ b/net-www/mod_auth_external/mod_auth_external-2.2.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_external/mod_auth_external-2.2.7.ebuild,v 1.1 2004/05/07 12:48:23 zul Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 authentication DSO using external programs"
+HOMEPAGE="http://www.unixpapa.com/mod_auth_external.html"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://www.unixpapa.com/software/${P}.tar.gz"
+DEPEND="sys-libs/pam =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} || die; cd ${S} || die; epatch ../${P}-gentoo.diff
+}
+
+src_compile() {
+ apxs2 -c ${PN}.c || die
+ cd pwauth
+ sed -i -e "s,\(LOCALFLAGS=\),\1$CFLAGS ,g" \
+ -e "s,\(LIB=.*\),\1 -lpam -ldl,g" Makefile
+ emake LIB="-lpam -ldl" || die "Make failed"
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so pwauth/unixgroup pwauth/pwauth
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/10_mod_auth_external.conf
+ insinto /etc/pam.d
+ newins ${FILESDIR}/pwauth.pam pwauth
+ newins ${FILESDIR}/pwauth.pam unixgroup
+
+ dodoc AUTHENTICATORS CHANGES INSTALL INSTALL.HARDCODE README TODO
+ docinto mysql; dodoc mysql/*
+ docinto pwauth; dodoc pwauth/{FORM_AUTH,INSTALL,README}
+ docinto radius; dodoc radius/{CHANGES,README}
+ docinto sybase; dodoc sybase/README
+ docinto test; dodoc test/*
+ dodoc ${FILESDIR}/10_mod_auth_external.conf
+
+ #protect these programs
+ local gid=`grep ^apache: /etc/group |cut -d: -f3`
+ [ -z "${gid}" ] && gid=81
+ fowners root:${gid} /usr/lib/apache2-extramodules/unixgroup
+ fowners root:${gid} /usr/lib/apache2-extramodules/pwauth
+ fperms 4710 /usr/lib/apache2-extramodules/unixgroup
+ fperms 4710 /usr/lib/apache2-extramodules/pwauth
+}