summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vinagre/ChangeLog7
-rw-r--r--net-misc/vinagre/vinagre-0.5.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/net-misc/vinagre/ChangeLog b/net-misc/vinagre/ChangeLog
index defd343abcac..7bd1a6649fb8 100644
--- a/net-misc/vinagre/ChangeLog
+++ b/net-misc/vinagre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vinagre
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.3 2008/03/25 16:16:54 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.4 2008/04/10 22:18:48 eva Exp $
+
+*vinagre-0.5.1 (10 Apr 2008)
+
+ 10 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org> +vinagre-0.5.1.ebuild:
+ bump to 0.5.1. Translation updates.
25 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org> vinagre-0.5.0.ebuild:
add gnome-doc-utils to DEPEND, fix bug #214722
diff --git a/net-misc/vinagre/vinagre-0.5.1.ebuild b/net-misc/vinagre/vinagre-0.5.1.ebuild
new file mode 100644
index 000000000000..aea71cbed725
--- /dev/null
+++ b/net-misc/vinagre/vinagre-0.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/vinagre-0.5.1.ebuild,v 1.1 2008/04/10 22:18:48 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="VNC Client for the GNOME Desktop"
+HOMEPAGE="http://www.gnome.org/projects/vinagre/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+IUSE="avahi test"
+
+RDEPEND=">=dev-libs/glib-2.15.3
+ >=x11-libs/gtk+-2.12
+ >=gnome-base/libglade-2.6
+ >=gnome-base/gconf-2.16
+ >=net-libs/gtk-vnc-0.3.3
+ >=gnome-base/gnome-keyring-1
+ avahi? ( >=net-dns/avahi-0.6.18 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ test? ( ~app-text/docbook-xml-dtd-4.3 )"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-dns/avahi gtk; then
+ eerror "gtk support in avahi needed"
+ die "Please rebuild avahi with USE='gtk'"
+ fi
+
+ G2CONF="${G2CONF} $(use_enable avahi) --disable-scrollkeeper"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Remove it's own installation of DOCS that go to $PN instead of $P and aren't ecompressed
+ rm -rf "${D}"/usr/share/doc/vinagre
+}