summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild')
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild b/net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..daed31f5cf70
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.2.3-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Bart Verwilst <verwilst@gentoo.org>
+# Modified by Ivan C. <navi_@hotmail.com>
+# $ Header: $
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
+HOMEPAGE="http://www.tightvnc.com"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.1.0
+ >=sys-devel/perl-5.6.1
+ ~media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.4"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ cd ${S}
+ xmkmf || die
+ make World || die
+ cd Xvnc
+ make World || die
+
+}
+
+src_install() {
+
+ cd ${S}
+ mkdir -p ${D}/usr/man
+ mkdir -p ${D}/usr/man/man1
+ mkdir -p ${D}/usr/bin
+
+ # fix the web based interface, it needs the java class files
+ mkdir -p ${D}/usr/share/tightvnc
+ mkdir -p ${D}/usr/share/tightvnc/classes
+ insinto /usr/share/tightvnc/classes ; doins classes/*
+
+ # and then patch vncserver to point to /usr/share/tightvnc/classes
+ patch -p0 < ${FILESDIR}/tightvnc-gentoo.diff || die
+
+ ./vncinstall ${D}/usr/bin ${D}/usr/man || die
+}