summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/ChangeLog7
-rw-r--r--net-misc/axel/axel-2.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-misc/axel/ChangeLog b/net-misc/axel/ChangeLog
index 26e6a057ec68..c8bf6710b878 100644
--- a/net-misc/axel/ChangeLog
+++ b/net-misc/axel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/axel
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.44 2009/01/25 01:56:11 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.45 2009/02/02 17:17:48 drizzt Exp $
+
+*axel-2.3 (02 Feb 2009)
+
+ 02 Feb 2009; <drizzt@gentoo.org> +axel-2.3.ebuild:
+ Version Bump
25 Jan 2009; Jeremy Olexa <darkside@gentoo.org>
-files/axel-1.0b-strcpy-fix.patch, -axel-1.0b.ebuild,
diff --git a/net-misc/axel/axel-2.3.ebuild b/net-misc/axel/axel-2.3.ebuild
new file mode 100644
index 000000000000..3cf18408971b
--- /dev/null
+++ b/net-misc/axel/axel-2.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-2.3.ebuild,v 1.1 2009/02/02 17:17:48 drizzt Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2287/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${PN}-1.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Set LDFLAGS and fix expr
+ sed -i -e 's/expr/& --/' -e "s/^LFLAGS=$/&${LDFLAGS}/" configure
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--debug=1"
+ use nls && myconf="--i18n=1"
+ econf \
+ --strip=0 \
+ --etcdir=/etc \
+ ${myconf} \
+ || die
+
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc API CHANGES CREDITS README axelrc.example
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND="/usr/bin/axel -a -o \${DISTDIR}/\${FILE} \${URI}"'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}