summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/autossh/autossh-1.2d.ebuild')
-rw-r--r--net-misc/autossh/autossh-1.2d.ebuild62
1 files changed, 31 insertions, 31 deletions
diff --git a/net-misc/autossh/autossh-1.2d.ebuild b/net-misc/autossh/autossh-1.2d.ebuild
index 6dc43521ed8b..6424f5626a92 100644
--- a/net-misc/autossh/autossh-1.2d.ebuild
+++ b/net-misc/autossh/autossh-1.2d.ebuild
@@ -1,36 +1,36 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.2d.ebuild,v 1.3 2003/07/13 14:31:35 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.2d.ebuild,v 1.4 2003/09/05 22:01:48 msterret Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Automatically restart SSH sessions and tunnels"
-HOMEPAGE="http://www.harding.motd.ca/autossh/"
-LICENSE="BSD"
-KEYWORDS="x86 ~sparc"
-SRC_URI="http://www.harding.motd.ca/autossh/${P}.tgz"
-SLOT="0"
-
-DEPEND="virtual/glibc
- sys-apps/sed"
-RDEPEND="virtual/glibc
- net-misc/openssh"
+S=${WORKDIR}/${P}
+DESCRIPTION="Automatically restart SSH sessions and tunnels"
+HOMEPAGE="http://www.harding.motd.ca/autossh/"
+LICENSE="BSD"
+KEYWORDS="x86 ~sparc"
+SRC_URI="http://www.harding.motd.ca/autossh/${P}.tgz"
+SLOT="0"
-src_unpack() {
- unpack ${A}
- cd ${S}
+DEPEND="virtual/glibc
+ sys-apps/sed"
+RDEPEND="virtual/glibc
+ net-misc/openssh"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ patch -p0 -l < ${FILESDIR}/${P}-reuse.patch
+ mv Makefile.linux Makefile.linux.orig
+ sed "s/CFLAGS=/CFLAGS=${CFLAGS}/g" Makefile.linux.orig >Makefile.linux
+}
+
+src_compile() {
+ emake -f Makefile.linux || die "make failed"
+}
+
+src_install() {
+ dobin autossh
+ dodoc CHANGES README autossh.host rscreen
+ doman autossh.1
+}
- patch -p0 -l < ${FILESDIR}/${P}-reuse.patch
- mv Makefile.linux Makefile.linux.orig
- sed "s/CFLAGS=/CFLAGS=${CFLAGS}/g" Makefile.linux.orig >Makefile.linux
-}
-
-src_compile() {
- emake -f Makefile.linux || die "make failed"
-}
-
-src_install() {
- dobin autossh
- dodoc CHANGES README autossh.host rscreen
- doman autossh.1
-}
-