summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/ezmlm-idx/ChangeLog10
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-7.0.0.ebuild62
-rw-r--r--net-mail/ezmlm-idx/metadata.xml2
3 files changed, 71 insertions, 3 deletions
diff --git a/net-mail/ezmlm-idx/ChangeLog b/net-mail/ezmlm-idx/ChangeLog
index 5f8c18b8a2db..420c26c83948 100644
--- a/net-mail/ezmlm-idx/ChangeLog
+++ b/net-mail/ezmlm-idx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/ezmlm-idx
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.18 2008/05/19 20:18:53 dev-zero Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.19 2009/01/02 10:33:17 hollow Exp $
+
+*ezmlm-idx-7.0.0 (02 Jan 2009)
+
+ 02 Jan 2009; Benedikt Böhm <hollow@gentoo.org> metadata.xml,
+ +ezmlm-idx-7.0.0.ebuild:
+ version bump wrt #215462
19 May 2008; Tiziano Müller <dev-zero@gentoo.org> ezmlm-idx-6.0.0.ebuild:
Changed dependency for postgresql to virtual/postgresql-base
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-7.0.0.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0.ebuild
new file mode 100644
index 000000000000..f327775f1925
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ezmlm-idx-7.0.0.ebuild,v 1.1 2009/01/02 10:33:17 hollow Exp $
+
+inherit qmail
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="http://www.ezmlm.org"
+SRC_URI="http://www.ezmlm.org/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+
+pkg_setup() {
+ if use mysql && use postgres; then
+ die "cannot build mysql and pgsql support at the same time"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+
+ echo /usr/bin > conf-bin
+ echo /usr/lib/ezmlm > conf-lib
+ echo /etc/ezmlm > conf-etc
+ echo /usr/share/man > conf-man
+ echo ${QMAIL_HOME} > conf-qmail
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc
+ echo $(tc-getCC) ${CFLAGS} > conf-ld
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/install\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile
+}
+
+src_compile() {
+ emake it man || die "make failed"
+
+ if use mysql; then
+ emake mysql || die "make mysql failed"
+ elif use postgres; then
+ emake pgsql || die "make pgsql failed"
+ fi
+}
+
+src_install () {
+ dodir /usr/bin /usr/lib/ezmlm /etc/ezmlm /usr/share/man
+ dobin ezmlm-cgi
+
+ make DESTDIR="${D}" setup || die "make setup failed"
+}
diff --git a/net-mail/ezmlm-idx/metadata.xml b/net-mail/ezmlm-idx/metadata.xml
index 51f94e3fbe0e..210ce3ffc25e 100644
--- a/net-mail/ezmlm-idx/metadata.xml
+++ b/net-mail/ezmlm-idx/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-mail</herd>
+<herd>qmail</herd>
</pkgmetadata>