summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ortp')
-rw-r--r--net-libs/ortp/ChangeLog11
-rw-r--r--net-libs/ortp/ortp-0.13.1-r1.ebuild43
-rw-r--r--net-libs/ortp/ortp-0.13.1.ebuild30
3 files changed, 52 insertions, 32 deletions
diff --git a/net-libs/ortp/ChangeLog b/net-libs/ortp/ChangeLog
index ce2dbfa96f19..bdf2de33278b 100644
--- a/net-libs/ortp/ChangeLog
+++ b/net-libs/ortp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/ortp
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ChangeLog,v 1.30 2008/08/16 15:39:08 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ChangeLog,v 1.31 2009/02/06 03:43:12 darkside Exp $
+
+*ortp-0.13.1-r1 (06 Feb 2009)
+
+ 06 Feb 2009; Jeremy Olexa <darkside@gentoo.org> -ortp-0.13.1.ebuild,
+ +ortp-0.13.1-r1.ebuild:
+ (non maintainer commit) basically a rewrite of the ebuild by Mounir Lamouri
+ to fix many issues, bug 257029
16 Aug 2008; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove stkn from metadata.xml (#27693)
diff --git a/net-libs/ortp/ortp-0.13.1-r1.ebuild b/net-libs/ortp/ortp-0.13.1-r1.ebuild
new file mode 100644
index 000000000000..92714af80c71
--- /dev/null
+++ b/net-libs/ortp/ortp-0.13.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ortp-0.13.1-r1.ebuild,v 1.1 2009/02/06 03:43:12 darkside Exp $
+
+EAPI="2"
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP, RFC3550) stack"
+HOMEPAGE="http://www.linphone.org/index.php/eng/code_review/ortp/"
+SRC_URI="http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc ipv6"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ # to be sure doc is not compiled nor installed with -doc and doxygen inst
+ if ! use doc; then
+ sed -i -e 's/test $DOXYGEN != //' configure \
+ || die "patching configure failed"
+ fi
+}
+
+src_configure() {
+ # memcheck is for HP-UX only
+ # mode64bit adds +DA2.0W +DS2.0 CFLAGS wich are needed for HP-UX
+ # strict adds -Werror, don't want it
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ --disable-memcheck \
+ --disable-mode64bit \
+ --disable-strict \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
diff --git a/net-libs/ortp/ortp-0.13.1.ebuild b/net-libs/ortp/ortp-0.13.1.ebuild
deleted file mode 100644
index 1c1deac6cf54..000000000000
--- a/net-libs/ortp/ortp-0.13.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ortp-0.13.1.ebuild,v 1.4 2008/02/12 21:39:09 vapier Exp $
-
-DESCRIPTION="Open Real-time Transport Protocol (RTP) stack"
-HOMEPAGE="http://www.linphone.org/index.php/v2/code_review/ortp/"
-SRC_URI="http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="ipv6"
-
-DEPEND="=dev-libs/glib-2*
- >=dev-util/pkgconfig-0.9.0"
-RDEPEND="=dev-libs/glib-2*"
-
-src_compile() {
- econf \
- --disable-strict \
- $(use_enable ipv6) \
- || die 'configure failed'
- emake || die 'make compile failed'
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Make install failed"
- dodoc README ChangeLog AUTHORS TODO NEWS
- dodoc docs/*.txt
-}