summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libvncserver/libvncserver-0.9.9.ebuild')
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.9.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-libs/libvncserver/libvncserver-0.9.9.ebuild b/net-libs/libvncserver/libvncserver-0.9.9.ebuild
index ecaf3a1c47cc..3a8bb454e768 100644
--- a/net-libs/libvncserver/libvncserver-0.9.9.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/libvncserver-0.9.9.ebuild,v 1.3 2012/06/19 16:21:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/libvncserver-0.9.9.ebuild,v 1.4 2012/06/19 18:51:30 floppym Exp $
EAPI="4"
@@ -14,7 +14,7 @@ SRC_URI="http://libvncserver.sourceforge.net/LibVNCServer-${PV/_}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="+24bpp gcrypt gnutls ipv6 +jpeg ssl test threads +zlib"
+IUSE="+24bpp gcrypt gnutls ipv6 +jpeg +png ssl test threads +zlib"
DEPEND="
gcrypt? ( dev-libs/libgcrypt )
@@ -26,6 +26,7 @@ DEPEND="
ssl? ( dev-libs/openssl )
)
jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng:0 )
zlib? ( sys-libs/zlib )
"
RDEPEND="${DEPEND}"
@@ -50,6 +51,7 @@ src_configure() {
$(usex gnutls --without-ssl $(use_with ssl)) \
$(use_with ipv6) \
$(use_with jpeg) \
+ $(use_with png) \
$(use_with threads pthread) \
$(use_with zlib)
}