summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/quassel')
-rw-r--r--net-irc/quassel/ChangeLog8
-rw-r--r--net-irc/quassel/quassel-0.4.3-r50.ebuild122
-rw-r--r--net-irc/quassel/quassel-0.5.1.ebuild (renamed from net-irc/quassel/quassel-0.5.0.ebuild)2
3 files changed, 8 insertions, 124 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 5eb4efa8207c..b21dd968b74d 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.71 2009/11/04 23:29:11 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.72 2009/11/21 15:59:19 scarabeus Exp $
+
+*quassel-0.5.1 (21 Nov 2009)
+
+ 21 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ -quassel-0.4.3-r50.ebuild, -quassel-0.5.0.ebuild, +quassel-0.5.1.ebuild:
+ Version bump. Drop old.
04 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org> quassel-9999.ebuild:
Fix missing a in useflagname. Billie reported.
diff --git a/net-irc/quassel/quassel-0.4.3-r50.ebuild b/net-irc/quassel/quassel-0.4.3-r50.ebuild
deleted file mode 100644
index 699dc4359e1c..000000000000
--- a/net-irc/quassel/quassel-0.4.3-r50.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.3-r50.ebuild,v 1.1 2009/08/26 18:06:01 scarabeus Exp $
-
-EAPI="2"
-
-inherit cmake-utils eutils
-
-DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
-HOMEPAGE="http://quassel-irc.org/"
-SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
-
-LANGS="cs da de fr hu nb_NO ru sl tr"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-RDEPEND="
- dbus? ( x11-libs/qt-dbus:4 )
- monolithic? (
- dev-db/sqlite[threadsafe]
- x11-libs/qt-sql:4[sqlite]
- x11-libs/qt-script:4
- x11-libs/qt-gui:4
- kde? ( >=kde-base/kdelibs-4.1 )
- phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
- webkit? ( x11-libs/qt-webkit:4 )
- )
- !monolithic? (
- server? (
- dev-db/sqlite[threadsafe]
- x11-libs/qt-sql:4[sqlite]
- x11-libs/qt-script:4
- )
- X? (
- x11-libs/qt-gui:4
- kde? ( >=kde-base/kdelibs-4.1 )
- phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
- webkit? ( x11-libs/qt-webkit:4 )
- )
- )
- ssl? ( x11-libs/qt-core:4[ssl] )
- "
-DEPEND="${RDEPEND}"
-
-DOCS="AUTHORS ChangeLog README"
-
-pkg_setup() {
- if ! use monolithic && ! use server && ! use X ; then
- eerror "You have to build at least one of the monolithic client (USE=monolithic),"
- eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
- die "monolithic, server and X flag unset."
- fi
-}
-
-src_configure() {
- local MY_LANGUAGES=""
- for i in ${LINGUAS}; do
- MY_LANGUAGES="${i},${MY_LANGUAGES}"
- done
-
- local mycmakeargs="
- $(cmake-utils_use_want X QTCLIENT)
- $(cmake-utils_use_want server CORE)
- $(cmake-utils_use_want monolithic MONO)
- $(cmake-utils_use_with webkit WEBKIT)
- $(cmake-utils_use_with phonon PHONON)
- $(cmake-utils_use_with kde KDE)
- $(cmake-utils_use_with dbus DBUS)
- $(cmake-utils_use_with ssl OPENSSL)
- $(cmake-utils_use_with oxygen OXYGEN)
- -DEMBED_DATA=OFF
- -DLINGUAS=${MY_LANGUAGES}
- "
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use server ; then
- newinitd "${FILESDIR}"/quasselcore-2.init quasselcore || die "newinitd failed"
- newconfd "${FILESDIR}"/quasselcore-2.conf quasselcore || die "newconfd failed"
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/quassel.logrotate" quassel
-
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
- fi
-}
-
-pkg_postinst() {
- if use server ; then
- ewarn
- ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in ${ROOT%/}/etc/conf.d/quasselcore to your username."
- ewarn "Note: This is the user who runs the quasselcore and is independent"
- ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "${ROOT%/}/usr/share/doc/${PF}".
- elog "http://bugs.quassel-irc.org/wiki/quassel-irc/Manage_core_users provides"
- elog "some information on using the script."
- elog "To be sure nothing bad will happen you need to stop the quasselcore"
- elog "before adding more users."
- fi
-
- if ( use server || use monolithic ) && use ssl ; then
- elog
- elog "Information on how to enable SSL support for client/core connections"
- elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
- fi
-}
diff --git a/net-irc/quassel/quassel-0.5.0.ebuild b/net-irc/quassel/quassel-0.5.1.ebuild
index ea3a32b51279..9138c60f12da 100644
--- a/net-irc/quassel/quassel-0.5.0.ebuild
+++ b/net-irc/quassel/quassel-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.5.0.ebuild,v 1.2 2009/10/15 12:08:33 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.5.1.ebuild,v 1.1 2009/11/21 15:59:19 scarabeus Exp $
EAPI="2"