summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openfire/ChangeLog11
-rw-r--r--net-im/openfire/files/openfire-3.8.0-buildxml.patch20
-rw-r--r--net-im/openfire/openfire-3.8.0.ebuild102
3 files changed, 130 insertions, 3 deletions
diff --git a/net-im/openfire/ChangeLog b/net-im/openfire/ChangeLog
index 17036e0a26c3..5dea02e680a5 100644
--- a/net-im/openfire/ChangeLog
+++ b/net-im/openfire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/openfire
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.45 2012/06/26 19:25:47 slyfox Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.46 2013/02/19 09:07:18 slyfox Exp $
+
+*openfire-3.8.0 (19 Feb 2013)
+
+ 19 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/openfire-3.8.0-buildxml.patch, +openfire-3.8.0.ebuild:
+ Version bump (bug #457658 by Thomas Raschbacher).
*openfire-3.7.1-r1 (26 Jun 2012)
@@ -324,4 +330,3 @@
+wildfire-2.5.0.ebuild:
Initial import so that more users can start to test. Credits to all that
helped in bug #120513
-
diff --git a/net-im/openfire/files/openfire-3.8.0-buildxml.patch b/net-im/openfire/files/openfire-3.8.0-buildxml.patch
new file mode 100644
index 000000000000..ce2c8b38abff
--- /dev/null
+++ b/net-im/openfire/files/openfire-3.8.0-buildxml.patch
@@ -0,0 +1,20 @@
+diff --git a/build/build.xml b/build/build.xml
+index fc3b75f..4eacc95 100644
+--- a/build/build.xml
++++ b/build/build.xml
+@@ -1244,6 +1244,7 @@
+ </target>
+ <target name="-plugins-impl" if="dirlist">
+
++ <taskdef classname="net.sf.antcontrib.logic.For" name="for"/>
+ <!-- For each plugin in the main src dir, call the 'buildplugin' macro -->
+ <for list="${dirlist}" param="plugin" trim="true">
+ <sequential>
+@@ -1262,6 +1263,7 @@
+ </target>
+ <target name="-plugins-impl-dev" if="plugin.dev.dir" depends="anttasks">
+
++ <taskdef classname="net.sf.antcontrib.logic.For" name="for"/>
+ <!-- Get a list of plugins in the optional dev dir -->
+ <subdirinfo dir="${plugin.dev.dir}" property="dirlist2" ifexists="plugin.xml"/>
+
diff --git a/net-im/openfire/openfire-3.8.0.ebuild b/net-im/openfire/openfire-3.8.0.ebuild
new file mode 100644
index 000000000000..767ae321b525
--- /dev/null
+++ b/net-im/openfire/openfire-3.8.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/openfire-3.8.0.ebuild,v 1.1 2013/02/19 09:07:18 slyfox Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P=${PN}_src_${PV//./_}
+DESCRIPTION="Openfire (formerly wildfire) real time collaboration (RTC) server"
+HOMEPAGE="http://www.igniterealtime.org/projects/openfire/"
+SRC_URI="http://www.igniterealtime.org/builds/openfire/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="net-im/jabber-base
+ ~dev-java/ant-contrib-1.0_beta2
+ >=virtual/jdk-1.5"
+
+S=${WORKDIR}/${PN}_src
+
+RESTRICT=""
+
+pkg_setup() {
+ if [ -f /etc/env.d/98openfire ]; then
+ einfo "This is an upgrade"
+ ewarn "As the plugin API changed, at least these plugins need to be updated also:"
+ ewarn "User Search, IM Gateway, Fastpath, Monitoring"
+ ewarn "hey can be downloaded via Admin Console or at"
+ ewarn "${HOMEPAGE}"
+ else
+ ewarn "If this is an upgrade stop right ( CONTROL-C ) and run the command:"
+ ewarn "echo 'CONFIG_PROTECT=\"/opt/openfire/resources/security/\"' > /etc/env.d/98openfire "
+ ewarn "For more info see bug #139708"
+ sleep 11
+ fi
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-buildxml.patch
+ epatch "${FILESDIR}"/buildxml-ant.patch
+
+ # TODO should replace jars in build/lib with ones packaged by us -nichoj
+}
+
+src_compile() {
+ # Jikes doesn't support -source 1.5
+ java-pkg_filter-compiler jikes
+
+ ANT_TASKS="ant-contrib"
+ eant -f build/build.xml openfire plugins $(use_doc)
+}
+
+src_install() {
+ dodir /opt/openfire
+
+ newinitd "${FILESDIR}"/openfire-initd openfire
+ newconfd "${FILESDIR}"/openfire-confd openfire
+
+ dodir /opt/openfire/conf
+ insinto /opt/openfire/conf
+ newins target/openfire/conf/openfire.xml openfire.xml.sample
+
+ dodir /opt/openfire/logs
+ keepdir /opt/openfire/logs
+
+ dodir /opt/openfire/lib
+ insinto /opt/openfire/lib
+ doins target/openfire/lib/*
+
+ dodir /opt/openfire/plugins
+ insinto /opt/openfire/plugins
+ doins -r target/openfire/plugins/*
+
+ dodir /opt/openfire/resources
+ insinto /opt/openfire/resources
+ doins -r target/openfire/resources/*
+
+ if use doc; then
+ dohtml -r documentation/docs/*
+ fi
+ dodoc documentation/dist/*
+
+ #Protect ssl key on upgrade
+ dodir /etc/env.d/
+ echo 'CONFIG_PROTECT="/opt/openfire/resources/security/"' > "${D}"/etc/env.d/98openfire
+}
+
+pkg_postinst() {
+ chown -R jabber:jabber /opt/openfire
+
+ ewarn If this is a new install, please edit /opt/openfire/conf/openfire.xml.sample
+ ewarn and save it as /opt/openfire/conf/openfire.xml
+ ewarn
+ ewarn The following must be be owned or writable by the jabber user.
+ ewarn /opt/openfire/conf/openfire.xml
+}