summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/yafc')
-rw-r--r--net-ftp/yafc/ChangeLog7
-rw-r--r--net-ftp/yafc/files/yafc-1.1.1-heimdal_gssapi_fix.patch30
-rw-r--r--net-ftp/yafc/yafc-1.1.1-r1.ebuild8
3 files changed, 42 insertions, 3 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
index 1ec835c106ed..4c669651fc01 100644
--- a/net-ftp/yafc/ChangeLog
+++ b/net-ftp/yafc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/yafc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.32 2007/06/19 13:28:07 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.33 2007/09/23 15:32:56 fmccor Exp $
+
+ 23 Sep 2007; Ferris McCormick <fmccor@gentoo.org>
+ +files/yafc-1.1.1-heimdal_gssapi_fix.patch, yafc-1.1.1-r1.ebuild:
+ Apply patch for heimdal fix, Bug #113052 --- thanks to jmbsvicetto (Jorge M.
+ B. S. Vicetto).
19 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> yafc-1.1.1-r1.ebuild:
Stable on sparc wrt #173646
diff --git a/net-ftp/yafc/files/yafc-1.1.1-heimdal_gssapi_fix.patch b/net-ftp/yafc/files/yafc-1.1.1-heimdal_gssapi_fix.patch
new file mode 100644
index 000000000000..f6e35a8dcfec
--- /dev/null
+++ b/net-ftp/yafc/files/yafc-1.1.1-heimdal_gssapi_fix.patch
@@ -0,0 +1,30 @@
+diff -udNr yafc-1.1.1/cf/kerberos.m4 yafc-1.1.1-r1/cf/kerberos.m4
+--- yafc-1.1.1/cf/kerberos.m4 2002-12-05 17:10:55.000000000 -0500
++++ yafc-1.1.1-r1/cf/kerberos.m4 2005-11-20 02:26:35.000000000 -0500
+@@ -285,6 +285,10 @@
+ [
+ #include <gssapi/gssapi.h>
+ ])
++ AC_CHECK_HEADERS([gssapi/krb5_err.h],,,
++ [
++#include <gssapi/krb5_err.h>
++ ])
+ fi
+ fi
+ if test "$yafc_found_gssapi_inc" = "yes"; then
+diff -udNr yafc-1.1.1/lib/gssapi.c yafc-1.1.1-r1/lib/gssapi.c
+--- yafc-1.1.1/lib/gssapi.c 2005-11-20 02:30:15.375703984 -0500
++++ yafc-1.1.1-r1/lib/gssapi.c 2005-11-20 02:29:43.000000000 -0500
+@@ -51,6 +51,12 @@
+ # if defined(HAVE_GSSAPI_GSSAPI_KRB5_H)
+ # include <gssapi/gssapi_krb5.h>
+ # endif
++ /* This is needed in Gentoo's Heimdal install which correctly creates
++ * symlinks to match MIT's distribution locations for gssapi/*.h
++ */
++# if defined(HAVE_GSSAPI_KRB5_ERR_H)
++# include <gssapi/krb5_err.h>
++# endif
+ #else
+ # error "Need gssapi.h from either Heimdal or MIT krb5"
+ #endif
diff --git a/net-ftp/yafc/yafc-1.1.1-r1.ebuild b/net-ftp/yafc/yafc-1.1.1-r1.ebuild
index 0a07d7920363..916643f5e776 100644
--- a/net-ftp/yafc/yafc-1.1.1-r1.ebuild
+++ b/net-ftp/yafc/yafc-1.1.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1-r1.ebuild,v 1.5 2007/06/19 13:28:07 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1-r1.ebuild,v 1.6 2007/09/23 15:32:56 fmccor Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Console ftp client with a lot of nifty features"
HOMEPAGE="http://yafc.sourceforge.net/"
@@ -23,6 +23,10 @@ src_unpack() {
unpack "${A}"
cd "${S}"
epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch ${FILESDIR}/${P}-heimdal_gssapi_fix.patch
+
+ AT_M4DIR="cf"
+ eautoreconf
}
src_compile() {