summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/davfs2/davfs2-0.2.3.ebuild')
-rw-r--r--net-fs/davfs2/davfs2-0.2.3.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-fs/davfs2/davfs2-0.2.3.ebuild b/net-fs/davfs2/davfs2-0.2.3.ebuild
index 5ee3a330aa0a..5efdb1dfeac5 100644
--- a/net-fs/davfs2/davfs2-0.2.3.ebuild
+++ b/net-fs/davfs2/davfs2-0.2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-0.2.3.ebuild,v 1.1 2004/11/24 19:55:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-0.2.3.ebuild,v 1.2 2004/11/27 14:12:32 genstef Exp $
-inherit kernel-mod
+inherit kernel-mod eutils
IUSE="ssl"
@@ -12,7 +12,9 @@ HOMEPAGE="http://dav.sourceforge.net"
KEYWORDS="~x86 ~ppc"
LICENSE="GPL-2"
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ dev-libs/libxml2
+ sys-libs/zlib"
SLOT="0"
pkg_setup() {
@@ -27,6 +29,12 @@ pkg_setup() {
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}.nokernelsrc.patch
+}
+
src_compile() {
econf $(use_with ssl) || die "econf failed"
emake || die "emake failed"
@@ -34,4 +42,6 @@ src_compile() {
src_install() {
einstall || die "einstall failed"
+
+ dodoc BUGS ChangeLog FAQ README THANKS TODO
}