summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/diald/files')
-rw-r--r--net-dialup/diald/files/diald-1.0-gentoo.patch11
-rw-r--r--net-dialup/diald/files/diald-1.0-posix.patch42
-rw-r--r--net-dialup/diald/files/digest-diald-1.0-r12
3 files changed, 44 insertions, 11 deletions
diff --git a/net-dialup/diald/files/diald-1.0-gentoo.patch b/net-dialup/diald/files/diald-1.0-gentoo.patch
index b4cbaa6138bd..17f9b394cb48 100644
--- a/net-dialup/diald/files/diald-1.0-gentoo.patch
+++ b/net-dialup/diald/files/diald-1.0-gentoo.patch
@@ -1,14 +1,3 @@
-diff -Nru diald-1.0.orig/diald.h diald-1.0/diald.h
---- diald-1.0.orig/diald.h 2001-06-16 19:01:25.000000000 +0300
-+++ diald-1.0/diald.h 2005-09-19 23:40:47.840664536 +0300
-@@ -11,6 +11,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <stddef.h>
-+# include <time.h>
- #if HAVE_UNISTD_H
- # include <unistd.h>
- #endif
diff -Nru diald-1.0.orig/Makefile.in diald-1.0/Makefile.in
--- diald-1.0.orig/Makefile.in 2001-06-16 14:16:04.000000000 +0300
+++ diald-1.0/Makefile.in 2005-09-19 23:40:47.855662256 +0300
diff --git a/net-dialup/diald/files/diald-1.0-posix.patch b/net-dialup/diald/files/diald-1.0-posix.patch
new file mode 100644
index 000000000000..3ff13ab9bdbc
--- /dev/null
+++ b/net-dialup/diald/files/diald-1.0-posix.patch
@@ -0,0 +1,42 @@
+diff -Nru diald-1.0.orig/diald.h diald-1.0/diald.h
+--- diald-1.0.orig/diald.h 2001-06-16 19:01:25.000000000 +0300
++++ diald-1.0/diald.h 2006-09-21 15:58:57.000000000 +0300
+@@ -31,6 +31,10 @@
+ #if HAVE_SYS_TIME_H
+ # include <sys/time.h>
+ #endif
++#include <time.h>
++#ifndef CLK_TCK
++# define CLK_TCK (CLOCKS_PER_SEC)
++#endif
+ #ifdef _POSIX_PRIORITY_SCHEDULING
+ # include <sched.h>
+ #endif
+diff -Nru diald-1.0.orig/firewall.c diald-1.0/firewall.c
+--- diald-1.0.orig/firewall.c 2006-09-21 16:08:18.000000000 +0300
++++ diald-1.0/firewall.c 2006-09-21 15:49:12.000000000 +0300
+@@ -69,7 +69,7 @@
+ #if 0
+ mon_syslog(LOG_DEBUG,"slot def: %d %d %x %x %x",
+ slot->start, slot->end, slot->wday, slot->mday, slot->month);
+-#endif 0
++#endif
+ if ((slot->start <= ctime)
+ && (ctime <= slot->end)
+ && (slot->wday & (1<<ltime->tm_wday))
+diff -Nru diald-1.0.orig/log.c diald-1.0/log.c
+--- diald-1.0.orig/log.c 2001-06-16 22:51:39.000000000 +0300
++++ diald-1.0/log.c 2006-09-21 16:05:11.000000000 +0300
+@@ -19,10 +19,8 @@
+ xstrerror(int n)
+ {
+ static char buf[30];
+-
+- if (n >= 0 && n < sys_nerr)
+- return (char *)sys_errlist[n];
+- sprintf(buf, "Error code %d\n", n);
++ if (strerror_r(n, buf, 30) != 0)
++ sprintf(buf, "Error code %d\n", n);
+ return buf;
+ }
+
diff --git a/net-dialup/diald/files/digest-diald-1.0-r1 b/net-dialup/diald/files/digest-diald-1.0-r1
index f37ec4f53c3f..878db57d4da3 100644
--- a/net-dialup/diald/files/digest-diald-1.0-r1
+++ b/net-dialup/diald/files/digest-diald-1.0-r1
@@ -1 +1,3 @@
MD5 84a5aa3b8d1f12dd9e77f2b43b3d159a diald-1.0.tar.gz 199698
+RMD160 e73cb2b027ea5fa96ea9c89057a27600fe3146b9 diald-1.0.tar.gz 199698
+SHA256 dd7630811006ad0f49512de9f2fa6705e50fb475c5bb12e2dde77e198a863bd0 diald-1.0.tar.gz 199698