summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zabbix')
-rw-r--r--net-analyzer/zabbix/ChangeLog8
-rw-r--r--net-analyzer/zabbix/files/zabbix-1.8.3-as-needed.patch81
-rw-r--r--net-analyzer/zabbix/zabbix-1.8.3.ebuild8
3 files changed, 93 insertions, 4 deletions
diff --git a/net-analyzer/zabbix/ChangeLog b/net-analyzer/zabbix/ChangeLog
index 1aa4f359cf30..4fff383efd0e 100644
--- a/net-analyzer/zabbix/ChangeLog
+++ b/net-analyzer/zabbix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/zabbix
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.38 2010/09/12 20:24:04 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.39 2011/01/16 11:30:10 patrick Exp $
+
+ 16 Jan 2011; Patrick Lauer <patrick@gentoo.org> zabbix-1.8.3.ebuild,
+ +files/zabbix-1.8.3-as-needed.patch:
+ Fixing as-needed issues #333425
12 Sep 2010; Patrick Lauer <patrick@gentoo.org> -zabbix-1.8-r1.ebuild,
-zabbix-1.8.1.ebuild, -zabbix-1.8.2.ebuild:
diff --git a/net-analyzer/zabbix/files/zabbix-1.8.3-as-needed.patch b/net-analyzer/zabbix/files/zabbix-1.8.3-as-needed.patch
new file mode 100644
index 000000000000..33e6e65d591c
--- /dev/null
+++ b/net-analyzer/zabbix/files/zabbix-1.8.3-as-needed.patch
@@ -0,0 +1,81 @@
+From 90b086b4daebf61756e3d6f8926cf8951a2fc96a Mon Sep 17 00:00:00 2001
+From: Vladimir V. Kamarzin <vvk@altlinux.org>
+Date: Fri, 22 Oct 2010 17:47:01 +0600
+Subject: [PATCH 1/2] Fix linking with ldap libs
+
+Move "-lldap -llber" from LDAP_LDFLAGS to LDAP_LIBS and include them to
+LIBS
+---
+ configure.in | 1 +
+ m4/ldap.m4 | 4 +++-
+ 2 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index d3d981b..b11b2ee 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1221,6 +1221,7 @@ if test "x$want_ldap" = "xyes"; then
+ fi
+ CFLAGS="${CFLAGS} ${LDAP_CPPFLAGS}"
+ LDFLAGS="${LDFLAGS} ${LDAP_LDFLAGS}"
++LIBS="${LIBS} ${LDAP_LIBS}"
+
+ found_iconv="no"
+ dnl Check for libiconv [by default - skip]
+diff --git a/m4/ldap.m4 b/m4/ldap.m4
+index 29e97cd..885b3e0 100644
+--- a/m4/ldap.m4
++++ b/m4/ldap.m4
+@@ -72,7 +72,8 @@ AC_HELP_STRING([--with-ldap@<:@=DIR@:>@],[Include LDAP support @<:@default=no@:>
+ fi
+
+ LDAP_CPPFLAGS=-I$LDAP_INCDIR
+- LDAP_LDFLAGS="-L$LDAP_LIBDIR -lldap -llber $LDAP_LIBS"
++ LDAP_LDFLAGS="-L$LDAP_LIBDIR $LDAP_LIBS"
++ LDAP_LIBS="-lldap -llber $LDAP_LIBS"
+
+ found_ldap="yes"
+ AC_DEFINE(HAVE_LDAP,1,[Define to 1 if LDAP should be enabled.])
+@@ -92,6 +93,7 @@ AC_HELP_STRING([--with-ldap@<:@=DIR@:>@],[Include LDAP support @<:@default=no@:>
+
+ AC_SUBST(LDAP_CPPFLAGS)
+ AC_SUBST(LDAP_LDFLAGS)
++ AC_SUBST(LDAP_LIBS)
+
+ unset _libldap_with
+ ])dnl
+--
+1.7.3.1
+
+From f6378e6aeb0bec1883a83c70c8cdfd1213f11f97 Mon Sep 17 00:00:00 2001
+From: Vladimir V. Kamarzin <vvk@altlinux.org>
+Date: Fri, 22 Oct 2010 17:49:16 +0600
+Subject: [PATCH 2/2] m4/ax_lib_postgresql.m4: move -pq from POSTGRESQL_LDFLAGS to POSTGRESQL_LIBS
+
+---
+ m4/ax_lib_postgresql.m4 | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/m4/ax_lib_postgresql.m4 b/m4/ax_lib_postgresql.m4
+index fe06f66..934d12c 100644
+--- a/m4/ax_lib_postgresql.m4
++++ b/m4/ax_lib_postgresql.m4
+@@ -84,7 +84,8 @@ AC_DEFUN([AX_LIB_POSTGRESQL],
+ AC_MSG_CHECKING([for PostgreSQL libraries])
+
+ POSTGRESQL_CPPFLAGS="-I`$PG_CONFIG --includedir`"
+- POSTGRESQL_LDFLAGS="-L`$PG_CONFIG --libdir` -lpq"
++ POSTGRESQL_LDFLAGS="-L`$PG_CONFIG --libdir`"
++ POSTGRESQL_LIBS="-lpq"
+
+ POSTGRESQL_VERSION=`$PG_CONFIG --version | sed -e 's#PostgreSQL ##'`
+
+@@ -179,4 +180,5 @@ PQserverVersion(conn);
+ AC_SUBST([POSTGRESQL_VERSION])
+ AC_SUBST([POSTGRESQL_CPPFLAGS])
+ AC_SUBST([POSTGRESQL_LDFLAGS])
++ AC_SUBST([POSTGRESQL_LIBS])
+ ])
+--
+1.7.3.1
+
diff --git a/net-analyzer/zabbix/zabbix-1.8.3.ebuild b/net-analyzer/zabbix/zabbix-1.8.3.ebuild
index ee8e0997b3cd..23e42f90c0a8 100644
--- a/net-analyzer/zabbix/zabbix-1.8.3.ebuild
+++ b/net-analyzer/zabbix/zabbix-1.8.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.8.3.ebuild,v 1.4 2010/09/12 16:09:28 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.8.3.ebuild,v 1.5 2011/01/16 11:30:10 patrick Exp $
EAPI="2"
@@ -42,6 +42,10 @@ DEPEND="${COMMON_DEPEND}
useq frontend && need_php_httpd
+src_prepare() {
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+}
+
pkg_setup() {
if useq server || useq proxy ; then
local dbnum dbtypes="mysql oracle postgres sqlite3" dbtype