summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog7
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.4.10.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index b006d8ac3a7a..e1e4d4a3d0b8 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pnp4nagios
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.2 2008/06/08 13:34:34 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.3 2008/06/27 12:18:43 caleb Exp $
+
+*pnp4nagios-0.4.10 (27 Jun 2008)
+
+ 27 Jun 2008; Caleb Tennis <caleb@gentoo.org> +pnp4nagios-0.4.10.ebuild:
+ version bump, from bug #225381
08 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
pnp4nagios-0.4.7.ebuild:
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.4.10.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.4.10.ebuild
new file mode 100644
index 000000000000..8cc44b74cfb9
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.4.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.4.10.ebuild,v 1.1 2008/06/27 12:18:43 caleb Exp $
+
+inherit confutils
+
+MY_P=pnp-${PV}
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=dev-lang/php-4.3
+ >=net-analyzer/rrdtool-1.2
+ net-analyzer/nagios-core"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ confutils_require_built_with_all dev-lang/php gd pcre xml zlib
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --with-perfdata-dir=/var/nagios/perfdata \
+ --with-perfdata-spool-dir=/var/spool/pnp || die "econf failed"
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" fullinstall || die "emake install failed"
+}