summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsaplayer/ChangeLog9
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild99
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.80_rc3.ebuild (renamed from media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild)41
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.77-cxxflags.patch93
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.77-join-null-thread.patch12
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.77-ppc-endian-fix.patch21
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch62
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-flags.patch93
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-glib.patch11
-rw-r--r--media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r13
-rw-r--r--media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc13
-rw-r--r--media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc33
12 files changed, 136 insertions, 314 deletions
diff --git a/media-sound/alsaplayer/ChangeLog b/media-sound/alsaplayer/ChangeLog
index 593622278d42..a305b7ee93f8 100644
--- a/media-sound/alsaplayer/ChangeLog
+++ b/media-sound/alsaplayer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsaplayer
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.62 2007/07/14 18:39:11 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.63 2007/10/07 05:12:25 drac Exp $
+
+*alsaplayer-0.99.80_rc3 (07 Oct 2007)
+
+ 07 Oct 2007; Samuli Suominen <drac@gentoo.org>
+ +files/alsaplayer-0.99.80_rc3-flags.patch,
+ +files/alsaplayer-0.99.80_rc3-glib.patch, +alsaplayer-0.99.80_rc3.ebuild:
+ Version bump with patch removing deprecated GLIB 1.2 check.
14 Jul 2007; Samuli Suominen <drac@gentoo.org>
+files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch,
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild
deleted file mode 100644
index edbd0ad8894b..000000000000
--- a/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.77-r1.ebuild,v 1.2 2007/03/25 01:35:47 dirtyepic Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="A heavily multi-threaded pluggable audio player."
-HOMEPAGE="http://www.alsaplayer.org/"
-SRC_URI="http://www.alsaplayer.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
-IUSE="alsa audiofile doc esd flac gtk jack mikmod nas nls ogg opengl oss vorbis xosd"
-
-RDEPEND="
- media-libs/libsndfile
- alsa? ( media-libs/alsa-lib )
- audiofile? ( media-libs/audiofile )
- esd? ( media-sound/esound )
- flac? ( media-libs/flac )
- jack? ( >=media-sound/jack-audio-connection-kit-0.80.0 )
- mikmod? ( >=media-libs/libmikmod-3.1.10 )
- nas? ( media-libs/nas )
- ogg? ( media-libs/libogg )
- opengl? ( virtual/opengl )
- vorbis? ( media-libs/libvorbis )
- xosd? ( x11-libs/xosd )"
-
-DEPEND="${RDEPEND}
- =dev-libs/glib-1.2*
- gtk? ( =x11-libs/gtk+-1.2* )
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch "${FILESDIR}"/${P}-ppc-endian-fix.patch
- epatch "${FILESDIR}"/${P}-join-null-thread.patch
- epatch "${FILESDIR}"/${P}-cxxflags.patch
-
- eautoreconf
-}
-
-src_compile() {
- use xosd ||
- export ac_cv_lib_xosd_xosd_create="no"
-
- use doc ||
- export ac_cv_prog_HAVE_DOXYGEN="false"
-
- if use ogg && use flac; then
- myconf="${myconf} --enable-oggflac"
- fi
-
- econf \
- $(use_enable audiofile) \
- $(use_enable esd) \
- $(use_enable flac) \
- $(use_enable gtk gtk) \
- $(use_enable jack) \
- $(use_enable mikmod) \
- $(use_enable nas) \
- $(use_enable opengl) \
- $(use_enable oss) \
- $(use_enable nls) \
- $(use_enable sparc) \
- $(use_enable vorbis oggvorbis) \
- ${myconf} \
- --disable-gtk2 \
- --disable-sgi \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}" install \
- || die "make install failed"
-
- make_desktop_entry ${PN} "Alsaplayer" ${PN} \
- "AudioVideo;Audio;Player"
-
- dodoc AUTHORS ChangeLog README TODO
- dodoc docs/wishlist.txt
-}
-
-pkg_postinst() {
- if use gtk; then
- elog
- elog "The GTK-1 interface is known to crash with unicode filenames. If you"
- elog "experience such crashes, consider using the text interface (\`alsaplayer -i"
- elog "text\`), or trying another audio player."
- elog
- fi
-}
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.80_rc3.ebuild
index b9eac4963b49..02b806290c05 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.80_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild,v 1.3 2007/07/14 18:39:11 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.80_rc3.ebuild,v 1.1 2007/10/07 05:12:25 drac Exp $
inherit eutils autotools versionator
@@ -15,13 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
IUSE="alsa audiofile doc esd flac gtk jack mikmod nas ogg opengl oss vorbis xosd"
-RDEPEND="media-libs/alsa-lib
+RDEPEND="alsa? ( media-libs/alsa-lib )
media-libs/libsndfile
media-libs/libmad
audiofile? ( media-libs/audiofile )
esd? ( media-sound/esound )
- flac? ( >=media-libs/flac-1.1.3 )
- jack? ( >=media-sound/jack-audio-connection-kit-0.80.0 )
+ flac? ( media-libs/flac )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.80 )
mikmod? ( >=media-libs/libmikmod-3.1.10 )
nas? ( media-libs/nas )
ogg? ( media-libs/libogg )
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
>=dev-libs/glib-2.10.1
dev-util/pkgconfig
sys-devel/gettext
- gtk? ( >=x11-libs/gtk+-2.8.0 )
+ gtk? ( >=x11-libs/gtk+-2.8 )
doc? ( app-doc/doxygen )"
S="${WORKDIR}"/${PN}-${MY_PV}
@@ -40,23 +40,27 @@ S="${WORKDIR}"/${PN}-${MY_PV}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.99.77-cxxflags.patch
- epatch "${FILESDIR}"/${P}-amd64-flac-1.1.3.patch
+ epatch "${FILESDIR}"/${P}-glib.patch
+ epatch "${FILESDIR}"/${P}-flags.patch
eautoreconf
}
src_compile() {
- use xosd ||
- export ac_cv_lib_xosd_xosd_create="no"
+ use xosd || export ac_cv_lib_xosd_xosd_create="no"
+ use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
- use doc ||
- export ac_cv_prog_HAVE_DOXYGEN="false"
+ local myconf
+
+ if ! use alsa && ! use oss && ! use esd && ! use jack && ! use nas && ! use sparc; then
+ ewarn "You've disabled alsa, oss, esd, jack and nas. Enabling oss for you."
+ myconf="${myconf} --enable-oss"
+ fi
if use ogg && use flac; then
myconf="${myconf} --enable-oggflac"
fi
- econf \
+ econf --disable-gtk --disable-sgi \
$(use_enable audiofile) \
$(use_enable esd) \
$(use_enable flac) \
@@ -68,19 +72,16 @@ src_compile() {
$(use_enable oss) \
$(use_enable sparc) \
$(use_enable vorbis oggvorbis) \
- ${myconf} \
- --disable-gtk \
- --disable-sgi \
+ $(use_enable alsa) \
--disable-dependency-tracking \
- || die "econf failed"
+ ${myconf}
- emake || die "make failed"
+ emake || die "emake failed."
}
src_install() {
emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}" install \
- || die "make install failed"
+ || die "emake install failed."
- dodoc AUTHORS ChangeLog README TODO
- dodoc docs/wishlist.txt
+ dodoc AUTHORS ChangeLog README TODO docs/wishlist.txt
}
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.77-cxxflags.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.77-cxxflags.patch
deleted file mode 100644
index e3e3d234139b..000000000000
--- a/media-sound/alsaplayer/files/alsaplayer-0.99.77-cxxflags.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-diff -Naur alsaplayer-0.99.77-orig/app/Makefile.am alsaplayer-0.99.77/app/Makefile.am
---- alsaplayer-0.99.77-orig/app/Makefile.am 2003-02-09 13:37:55.000000000 -0600
-+++ alsaplayer-0.99.77/app/Makefile.am 2007-02-13 00:21:02.000000000 -0600
-@@ -27,8 +27,6 @@
-
- AM_CXXFLAGS = $(COMMON_FLAGS)
-
--AM_CFLAGS = $(CXXFLAGS)
--
- bin_PROGRAMS = alsaplayer
-
- alsaplayer_LDFLAGS = -export-dynamic
-diff -Naur alsaplayer-0.99.77-orig/configure.ac alsaplayer-0.99.77/configure.ac
---- alsaplayer-0.99.77-orig/configure.ac 2007-02-01 16:42:27.000000000 -0600
-+++ alsaplayer-0.99.77/configure.ac 2007-02-13 00:20:22.000000000 -0600
-@@ -589,14 +589,14 @@
-
- AC_MSG_CHECKING(for gcc optimization flags)
- old_cflags=$CFLAGS
--CFLAGS="$CFLAGS -O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
-+CFLAGS="$CFLAGS"
- AC_TRY_COMPILE([#include <stdio.h>],
- [ printf ("hello, world"); ],
--[ EXTRA_OPT_CFLAGS="-O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"],[ EXTRA_OPT_CFLAGS=""])
-+[ EXTRA_OPT_CFLAGS="$CFLAGS"],[ EXTRA_OPT_CFLAGS=""])
- CFLAGS=$old_cflags
- AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
-
--ARCH_CFLAGS="$EXTRA_OPT_CFLAGS $CFLAGS"
-+ARCH_CFLAGS="$EXTRA_OPT_CFLAGS"
-
- if test "$ARCH_TYPE" = "i486" || test "$ARCH_TYPE" = "i586" || test "$ARCH_TYPE" = "i686"
- then
-diff -Naur alsaplayer-0.99.77-orig/input/mad/Makefile.am alsaplayer-0.99.77/input/mad/Makefile.am
---- alsaplayer-0.99.77-orig/input/mad/Makefile.am 2003-02-09 13:37:56.000000000 -0600
-+++ alsaplayer-0.99.77/input/mad/Makefile.am 2007-02-13 00:21:35.000000000 -0600
-@@ -28,8 +28,6 @@
-
- AM_CFLAGS = $(COMMON_CFLAGS)
-
--AM_CXXFLAGS = $(CFLAGS)
--
- INCLUDES = -I$(ROOT_DIR)/app $(GLIB_CFLAGS)
-
- libmad_in_la_SOURCES = $(mad_insources)
-diff -Naur alsaplayer-0.99.77-orig/interface/daemon/Makefile.am alsaplayer-0.99.77/interface/daemon/Makefile.am
---- alsaplayer-0.99.77-orig/interface/daemon/Makefile.am 2003-02-16 12:23:18.000000000 -0600
-+++ alsaplayer-0.99.77/interface/daemon/Makefile.am 2007-02-13 00:22:14.000000000 -0600
-@@ -10,8 +10,6 @@
- -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
- -DADDON_DIR=\"$(ADDON_DIR)\"
-
--AM_CFLAGS = $(CXXFLAGS)
--
- libdir = $(ADDON_DIR)/interface
-
- libdaemon_interface_la_LDFLAGS = $(daemon_interfaceldflags)
-diff -Naur alsaplayer-0.99.77-orig/interface/gtk/Makefile.am alsaplayer-0.99.77/interface/gtk/Makefile.am
---- alsaplayer-0.99.77-orig/interface/gtk/Makefile.am 2003-02-16 12:23:19.000000000 -0600
-+++ alsaplayer-0.99.77/interface/gtk/Makefile.am 2007-02-13 00:22:36.000000000 -0600
-@@ -25,8 +25,6 @@
- @GLIB_CFLAGS@ @GTK_CFLAGS@ $(COMMON_FLAGS) \
- -D_REENTRANT -DADDON_DIR=\"$(ADDON_DIR)\"
-
--AM_CFLAGS = $(CXXFLAGS)
--
- libdir = $(ADDON_DIR)/interface
-
- libgtk_interface_la_LDFLAGS = $(gtk_interfaceldflags)
-diff -Naur alsaplayer-0.99.77-orig/interface/text/Makefile.am alsaplayer-0.99.77/interface/text/Makefile.am
---- alsaplayer-0.99.77-orig/interface/text/Makefile.am 2003-02-16 12:23:19.000000000 -0600
-+++ alsaplayer-0.99.77/interface/text/Makefile.am 2007-02-13 00:23:35.000000000 -0600
-@@ -10,8 +10,6 @@
- -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
- -DADDON_DIR=\"$(ADDON_DIR)\"
-
--AM_CFLAGS = $(CXXFLAGS)
--
- libdir = $(ADDON_DIR)/interface
-
- libtext_interface_la_LDFLAGS = $(text_interfaceldflags)
-diff -Naur alsaplayer-0.99.77-orig/interface/xosd/Makefile.am alsaplayer-0.99.77/interface/xosd/Makefile.am
---- alsaplayer-0.99.77-orig/interface/xosd/Makefile.am 2003-02-16 12:23:21.000000000 -0600
-+++ alsaplayer-0.99.77/interface/xosd/Makefile.am 2007-02-13 00:25:00.000000000 -0600
-@@ -22,8 +22,6 @@
- -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
- -DADDON_DIR=\"$(ADDON_DIR)\"
-
--AM_CFLAGS = $(CXXFLAGS)
--
- libdir = $(ADDON_DIR)/interface
-
- libxosd_interface_la_LDFLAGS = $(xosd_interfaceldflags)
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.77-join-null-thread.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.77-join-null-thread.patch
deleted file mode 100644
index 9f56b5f76cd2..000000000000
--- a/media-sound/alsaplayer/files/alsaplayer-0.99.77-join-null-thread.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur alsaplayer-0.99.77-orig/app/AlsaNode.cpp alsaplayer-0.99.77/app/AlsaNode.cpp
---- alsaplayer-0.99.77-orig/app/AlsaNode.cpp 2004-02-15 12:42:13.000000000 -0600
-+++ alsaplayer-0.99.77/app/AlsaNode.cpp 2007-02-13 00:14:29.000000000 -0600
-@@ -488,7 +488,7 @@
- looping = false;
- pthread_mutex_lock(&thread_mutex);
- if (thread_running) {
-- if (pthread_join(looper_thread, NULL)) {
-+ if (looper_thread != NULL && pthread_join(looper_thread, NULL)) {
- // Hmmm
- }
- thread_running = false;
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.77-ppc-endian-fix.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.77-ppc-endian-fix.patch
deleted file mode 100644
index 28e923958798..000000000000
--- a/media-sound/alsaplayer/files/alsaplayer-0.99.77-ppc-endian-fix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur alsaplayer-0.99.77-orig/output/alsa-0.5.x/alsa.c alsaplayer-0.99.77/output/alsa-0.5.x/alsa.c
---- alsaplayer-0.99.77-orig/output/alsa-0.5.x/alsa.c 2003-04-08 09:15:45.000000000 -0600
-+++ alsaplayer-0.99.77/output/alsa-0.5.x/alsa.c 2007-02-13 00:51:45.000000000 -0600
-@@ -121,7 +121,7 @@
- params.buf.block.frags_min = 1;
-
- memset(&format, 0, sizeof(format));
-- format.format = SND_PCM_SFMT_S16_LE;
-+ format.format = SND_PCM_SFMT_S16;
- format.rate = output_rate;
- format.voices = *channels;
- format.interleave = 1;
-@@ -166,7 +166,7 @@
- params.start_mode = SND_PCM_START_FULL;
- params.stop_mode = SND_PCM_STOP_STOP;
- memset(&format, 0, sizeof(format));
-- format.format = SND_PCM_SFMT_S16_LE;
-+ format.format = SND_PCM_SFMT_S16;
- format.rate = output_rate = rate;
- format.voices = 2;
- format.interleave = 1;
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch
deleted file mode 100644
index 27e842e19e68..000000000000
--- a/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- input/flac/FlacStream.h-dist 2007-04-25 14:44:52.000000000 +0200
-+++ input/flac/FlacStream.h 2007-04-25 14:45:11.000000000 +0200
-@@ -191,7 +191,7 @@ class FlacStream
-
- FLAC__StreamDecoderReadStatus
- realReadCallBack (FLAC__byte buffer[],
-- unsigned * bytes);
-+ size_t * bytes);
-
-
- protected:
-@@ -233,7 +233,7 @@ class FlacStream
- static FLAC__StreamDecoderReadStatus
- readCallBack (const FLAC__StreamDecoder * decoder,
- FLAC__byte buffer[],
-- unsigned * bytes,
-+ size_t * bytes,
- void * client_data);
-
- static void errCallBack (const FLAC__StreamDecoder * decoder,
---- input/flac/FlacStream.cpp-dist 2007-04-25 14:44:10.000000000 +0200
-+++ input/flac/FlacStream.cpp 2007-04-25 14:44:49.000000000 +0200
-@@ -321,7 +321,7 @@
-
-
- FLAC__StreamDecoderReadStatus
--FlacStream::realReadCallBack (FLAC__byte buffer[], unsigned * bytes)
-+FlacStream::realReadCallBack (FLAC__byte buffer[], size_t * bytes)
- {
- *bytes = reader_read (buffer, *bytes, _datasource);
- return *bytes > 0 ? FLAC__STREAM_DECODER_READ_STATUS_CONTINUE :
-@@ -336,7 +336,7 @@
- FLAC__StreamDecoderReadStatus
- FlacStream::readCallBack (const FLAC__StreamDecoder *,
- FLAC__byte buffer[],
-- unsigned * bytes,
-+ size_t * bytes,
- void * client_data)
- {
- if (!client_data)
---- input/flac/FlacSeekableStream.cpp-dist 2007-04-25 14:45:29.000000000 +0200
-+++ input/flac/FlacSeekableStream.cpp 2007-04-25 14:45:43.000000000 +0200
-@@ -255,7 +255,7 @@
- FlacSeekableStream::readCallBack (const FLAC__StreamDecoder * /*decoder*/,
- #endif
- FLAC__byte buffer[],
-- unsigned * bytes,
-+ size_t * bytes,
- void * client_data)
- {
- if (!client_data)
---- input/flac/FlacSeekableStream.h-dist 2007-04-25 14:45:32.000000000 +0200
-+++ input/flac/FlacSeekableStream.h 2007-04-25 14:45:53.000000000 +0200
-@@ -114,7 +114,7 @@ class FlacSeekableStream : public FlacSt
- readCallBack (const FLAC__StreamDecoder * decoder,
- #endif
- FLAC__byte buffer[],
-- unsigned * bytes,
-+ size_t * bytes,
- void * client_data);
-
- #ifdef LEGACY_FLAC
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-flags.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-flags.patch
new file mode 100644
index 000000000000..65c6ec45a6c5
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-flags.patch
@@ -0,0 +1,93 @@
+diff -ur alsaplayer-0.99.80-rc3.orig/app/Makefile.am alsaplayer-0.99.80-rc3/app/Makefile.am
+--- alsaplayer-0.99.80-rc3.orig/app/Makefile.am 2007-06-23 18:27:28.000000000 +0300
++++ alsaplayer-0.99.80-rc3/app/Makefile.am 2007-10-07 07:47:55.000000000 +0300
+@@ -29,8 +29,6 @@
+
+ AM_CXXFLAGS = $(COMMON_FLAGS)
+
+-AM_CFLAGS = $(CXXFLAGS)
+-
+ bin_PROGRAMS = alsaplayer
+
+ localedir = $(datadir)/locale
+diff -ur alsaplayer-0.99.80-rc3.orig/configure.ac alsaplayer-0.99.80-rc3/configure.ac
+--- alsaplayer-0.99.80-rc3.orig/configure.ac 2007-09-05 22:55:29.000000000 +0300
++++ alsaplayer-0.99.80-rc3/configure.ac 2007-10-07 07:49:09.000000000 +0300
+@@ -564,14 +564,14 @@
+
+ AC_MSG_CHECKING(for gcc optimization flags)
+ old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
++CFLAGS="$CFLAGS"
+ AC_TRY_COMPILE([#include <stdio.h>],
+ [ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="-O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"],[ EXTRA_OPT_CFLAGS=""])
++[ EXTRA_OPT_CFLAGS="$CFLAGS"],[ EXTRA_OPT_CFLAGS=""])
+ CFLAGS=$old_cflags
+ AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+
+-ARCH_CFLAGS="$EXTRA_OPT_CFLAGS $CFLAGS"
++ARCH_CFLAGS="$EXTRA_OPT_CFLAGS"
+
+ if test "$ARCH_TYPE" = "i486" || test "$ARCH_TYPE" = "i586" || test "$ARCH_TYPE" = "i686"
+ then
+diff -ur alsaplayer-0.99.80-rc3.orig/input/mad/Makefile.am alsaplayer-0.99.80-rc3/input/mad/Makefile.am
+--- alsaplayer-0.99.80-rc3.orig/input/mad/Makefile.am 2007-07-18 00:07:37.000000000 +0300
++++ alsaplayer-0.99.80-rc3/input/mad/Makefile.am 2007-10-07 07:49:28.000000000 +0300
+@@ -23,8 +23,6 @@
+
+ AM_CFLAGS = $(COMMON_CFLAGS)
+
+-AM_CXXFLAGS = $(CFLAGS)
+-
+ INCLUDES = -I$(ROOT_DIR)/app $(extra_cflags)
+
+ libmad_in_la_SOURCES = $(mad_insources)
+diff -ur alsaplayer-0.99.80-rc3.orig/interface/daemon/Makefile.am alsaplayer-0.99.80-rc3/interface/daemon/Makefile.am
+--- alsaplayer-0.99.80-rc3.orig/interface/daemon/Makefile.am 2007-06-13 22:33:45.000000000 +0300
++++ alsaplayer-0.99.80-rc3/interface/daemon/Makefile.am 2007-10-07 07:49:51.000000000 +0300
+@@ -10,8 +10,6 @@
+ -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
+ -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+-
+ libdir = $(ADDON_DIR)/interface
+
+ libdaemon_interface_la_LDFLAGS = $(daemon_interfaceldflags)
+diff -ur alsaplayer-0.99.80-rc3.orig/interface/gtk2/Makefile.am alsaplayer-0.99.80-rc3/interface/gtk2/Makefile.am
+--- alsaplayer-0.99.80-rc3.orig/interface/gtk2/Makefile.am 2007-06-20 22:16:41.000000000 +0300
++++ alsaplayer-0.99.80-rc3/interface/gtk2/Makefile.am 2007-10-07 07:50:28.000000000 +0300
+@@ -25,8 +25,6 @@
+ @GTK2_CFLAGS@ $(COMMON_FLAGS) \
+ -D_REENTRANT -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+-
+ libdir = $(ADDON_DIR)/interface
+
+ libgtk2_interface_la_LDFLAGS = $(gtk2_interfaceldflags)
+diff -ur alsaplayer-0.99.80-rc3.orig/interface/text/Makefile.am alsaplayer-0.99.80-rc3/interface/text/Makefile.am
+--- alsaplayer-0.99.80-rc3.orig/interface/text/Makefile.am 2007-06-13 22:33:46.000000000 +0300
++++ alsaplayer-0.99.80-rc3/interface/text/Makefile.am 2007-10-07 07:50:44.000000000 +0300
+@@ -10,8 +10,6 @@
+ -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
+ -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+-
+ libdir = $(ADDON_DIR)/interface
+
+ libtext_interface_la_LDFLAGS = $(text_interfaceldflags)
+diff -ur alsaplayer-0.99.80-rc3.orig/interface/xosd/Makefile.am alsaplayer-0.99.80-rc3/interface/xosd/Makefile.am
+--- alsaplayer-0.99.80-rc3.orig/interface/xosd/Makefile.am 2007-06-13 22:33:51.000000000 +0300
++++ alsaplayer-0.99.80-rc3/interface/xosd/Makefile.am 2007-10-07 07:50:59.000000000 +0300
+@@ -22,8 +22,6 @@
+ -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
+ -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+-
+ libdir = $(ADDON_DIR)/interface
+
+ libxosd_interface_la_LDFLAGS = $(xosd_interfaceldflags)
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-glib.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-glib.patch
new file mode 100644
index 000000000000..01f9622d2be2
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc3-glib.patch
@@ -0,0 +1,11 @@
+diff -ur alsaplayer-0.99.80-rc3.orig/configure.ac alsaplayer-0.99.80-rc3/configure.ac
+--- alsaplayer-0.99.80-rc3.orig/configure.ac 2007-09-05 22:55:29.000000000 +0300
++++ alsaplayer-0.99.80-rc3/configure.ac 2007-10-07 07:58:08.000000000 +0300
+@@ -62,7 +62,6 @@
+ AM_PROG_LIBTOOL
+ AM_PROG_CC_C_O
+ AC_PROG_MAKE_SET
+-AM_PATH_GLIB(1.2.6, have_glib=yes, have_glib=no)
+ AM_PATH_LIBMIKMOD(3.1.7, have_mikmod=yes, have_mikmod=no)
+ AM_PATH_OGG(have_ogg=yes, have_ogg=no)
+ AM_PATH_VORBIS(have_vorbis=yes, have_vorbis=no)
diff --git a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r1 b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r1
deleted file mode 100644
index 385f3c3f0ed7..000000000000
--- a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.77-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3280795b199ae1bb245559ccbbca5c02 alsaplayer-0.99.77.tar.bz2 657622
-RMD160 a40c25f17ec6f4f81283bb2ee91c0bee27e1a108 alsaplayer-0.99.77.tar.bz2 657622
-SHA256 5bfcbb14f5c64f0d5fd56420910f192a1bebac99c8a6e53855a69f64a3f3d6a0 alsaplayer-0.99.77.tar.bz2 657622
diff --git a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc1 b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc1
deleted file mode 100644
index 63e1207a382d..000000000000
--- a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 be009d4da07d289c62c7cec36ce2cdd5 alsaplayer-0.99.80-rc1.tar.bz2 789763
-RMD160 1ec76d6847ff1068cd33c6d1f0d380a7114e0c13 alsaplayer-0.99.80-rc1.tar.bz2 789763
-SHA256 3b6e10ceec44279bf251e884ec5a293b236109c511d3fbb332ba4ee2168782b8 alsaplayer-0.99.80-rc1.tar.bz2 789763
diff --git a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc3 b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc3
new file mode 100644
index 000000000000..821da1766784
--- /dev/null
+++ b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.80_rc3
@@ -0,0 +1,3 @@
+MD5 fbbca7d3a76dd4d5045c4c974001e517 alsaplayer-0.99.80-rc3.tar.bz2 804855
+RMD160 c79fd29c0466f9c3897af01c058bea19ef096e6b alsaplayer-0.99.80-rc3.tar.bz2 804855
+SHA256 b66f1c1579d5053d9b06eddeae9252cb9c427e7e22512346bb7236c61ea23fe7 alsaplayer-0.99.80-rc3.tar.bz2 804855