summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ecasound/ChangeLog8
-rw-r--r--media-sound/ecasound/Manifest14
-rw-r--r--media-sound/ecasound/ecasound-2.4.2.ebuild110
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.4.21
4 files changed, 121 insertions, 12 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 9117dd397d48..7fadb2e06579 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ecasound
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.28 2005/04/21 21:36:41 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.29 2005/08/10 20:54:34 kito Exp $
+
+*ecasound-2.4.2 (07 Aug 2005)
+
+ 07 Aug 2005; Kito <kito@gentoo.org> +ecasound-2.4.2.ebuild:
+ version bump. Ebuild cleanup, several use flags added -
+ debug,ruby,sndfile,libsamplerate.
*ecasound-2.4.1 (21 Apr 2005)
diff --git a/media-sound/ecasound/Manifest b/media-sound/ecasound/Manifest
index 46be0ff5e58d..ff7b903623e2 100644
--- a/media-sound/ecasound/Manifest
+++ b/media-sound/ecasound/Manifest
@@ -1,20 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 645ef3a7395b7d275bba7fecde7ea5ea ChangeLog 4572
MD5 30e1470186dc77519efe49f24e57034d ecasound-2.3.2.ebuild 2761
MD5 e2dde7f7b26f4a5ca5197827737fdf69 ecasound-2.3.3.ebuild 2810
MD5 965b9d8fa98e77692e62daf704bbf244 ecasound-2.4.0.ebuild 2812
MD5 74d23aed17332b5f6ea7d949302d7bef ecasound-2.4.1.ebuild 2873
+MD5 e37c818dd45252fef86d512d472585b3 ecasound-2.4.2.ebuild 3099
+MD5 eadab3941f136b871837953c9d1472d5 metadata.xml 753
MD5 e68dadbc41193dfa31762ee90a4b2271 files/digest-ecasound-2.3.2 66
MD5 92bd0b879f6e514225f5db2a2d474688 files/digest-ecasound-2.3.3 66
MD5 6a3363beab079c4f667c48d887782a04 files/digest-ecasound-2.4.0 66
MD5 a17b7c260bfe07eb12d6b70ffcfbe01b files/digest-ecasound-2.4.1 67
-MD5 eadab3941f136b871837953c9d1472d5 metadata.xml 753
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC0CCjI1lqEGTUzyQRAinZAJ9z41jY6OmzmG57KnKt5XCiEspHNACgqJqE
-3HIwIqnHcQCM8vMUNzVu2Bs=
-=aq31
------END PGP SIGNATURE-----
+MD5 ad606cf29183d19c00c3f0c8679b759d files/digest-ecasound-2.4.2 67
diff --git a/media-sound/ecasound/ecasound-2.4.2.ebuild b/media-sound/ecasound/ecasound-2.4.2.ebuild
new file mode 100644
index 000000000000..330aeb348d04
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.4.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.2.ebuild,v 1.1 2005/08/10 20:54:34 kito Exp $
+
+IUSE="alsa arts audiofile debug jack libsamplerate mikmod ncurses oggvorbis oss pic python ruby sndfile"
+
+DESCRIPTION="A package for multitrack audio processing"
+SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
+HOMEPAGE="http://eca.cx/"
+LICENSE="GPL-2"
+
+SLOT="1"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~ppc-macos"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib )
+ oggvorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ libsamplerate? ( media-libs/libsamplerate )
+ mikmod? ( media-libs/libmikmod )
+ ruby? ( dev-lang/ruby )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )
+ sndfile? ( media-libs/libsndfile )"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i 's:map.h:map:g' configure
+}
+
+src_compile () {
+ local myconf
+
+ myconf="${myconf} --enable-shared --with-largefile"
+
+ use amd64 && myconf="${myconf} --with-pic"
+
+ if use python; then
+ #
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ #
+ local python_version python_prefix python_includes python_modules
+ if use userland_Darwin ; then
+ myconf="$myconf --enable-pyecasound=python"
+ else
+ myconf="$myconf --enable-pyecasound=c"
+ fi
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/lib/python$python_version"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ econf \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable ncurses) \
+ $(use_enable oss) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ $(use_with pic) \
+ ${myconf} \
+ || die "configure failed"
+ make || die "build failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use python; then
+ cd pyecasound || die
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc INSTALL FAQ BUGS COPYING NEWS README TODO
+ dohtml `find Documentation -name "*.html"`
+ dodoc Documentation/edi-list.txt
+}
+
+pkg_postinst() {
+ if use arts; then
+ ewarn "WARNING: You have requested ecasound ARTS support,"
+ ewarn "this is no longer supported and will go away in"
+ ewarn "future releases."
+ fi
+}
+
diff --git a/media-sound/ecasound/files/digest-ecasound-2.4.2 b/media-sound/ecasound/files/digest-ecasound-2.4.2
new file mode 100644
index 000000000000..9395bc9b44b7
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.4.2
@@ -0,0 +1 @@
+MD5 77c10152f5a15da13f7876f0da30d592 ecasound-2.4.2.tar.gz 1109020