summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/chordii/ChangeLog10
-rw-r--r--media-sound/chordii/chordii-4.3.ebuild37
-rw-r--r--media-sound/chordii/metadata.xml28
3 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/chordii/ChangeLog b/media-sound/chordii/ChangeLog
new file mode 100644
index 000000000000..08930ad59b18
--- /dev/null
+++ b/media-sound/chordii/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/chordii
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/chordii/ChangeLog,v 1.1 2011/05/18 07:37:52 radhermit Exp $
+
+*chordii-4.3 (18 May 2011)
+
+ 18 May 2011; Tim Harder <radhermit@gentoo.org> +chordii-4.3.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/media-sound/chordii/chordii-4.3.ebuild b/media-sound/chordii/chordii-4.3.ebuild
new file mode 100644
index 000000000000..75611ec909cc
--- /dev/null
+++ b/media-sound/chordii/chordii-4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/chordii/chordii-4.3.ebuild,v 1.1 2011/05/18 07:37:52 radhermit Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="A guitar music typesetter"
+HOMEPAGE="http://chordii.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${P}-user_guide.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ sed -i -e "/dist_man_MAN/d" man/Makefile.am
+ eautomake
+}
+
+src_install() {
+ default
+
+ use doc && dodoc "${DISTDIR}"/${P}-user_guide.pdf
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/media-sound/chordii/metadata.xml b/media-sound/chordii/metadata.xml
new file mode 100644
index 000000000000..b3ad0adf8f45
--- /dev/null
+++ b/media-sound/chordii/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ Chordii is a fork of Chord, a program very popular several years
+ ago and most famous for its trendsetting 'ChordPro' music file format.
+
+ Chordii's purpose is to provide guitar players with a tool to produce
+ good looking, self-descriptive music sheets from text files.
+
+ Chordii reads a text file containing the lyrics of a song, the chords
+ to be played, their description and some other optional data to
+ produce a PostScript document that includes:
+
+ * Centered titles
+ * Chord names above the words
+ * Graphical representation of the chords at the end of the songs
+ * Transposition
+ * Multiple columns on a page
+ * Index of a songbook
+ * Multiple logical pages per physical pages (1, 2 or 4)
+ * Configurable fonts for the lyrics and the chord names
+ * Multiple songs inside one file
+ * The complete ISO 8859-1 character set
+ * Chorus marking
+ </longdescription>
+</pkgmetadata>