summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/zinf/zinf-2.2.5-r1.ebuild')
-rw-r--r--media-sound/zinf/zinf-2.2.5-r1.ebuild81
1 files changed, 53 insertions, 28 deletions
diff --git a/media-sound/zinf/zinf-2.2.5-r1.ebuild b/media-sound/zinf/zinf-2.2.5-r1.ebuild
index ec8f529c99cc..66861851238c 100644
--- a/media-sound/zinf/zinf-2.2.5-r1.ebuild
+++ b/media-sound/zinf/zinf-2.2.5-r1.ebuild
@@ -1,57 +1,73 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.5-r1.ebuild,v 1.1 2004/04/16 10:00:34 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.5-r1.ebuild,v 1.1.1.1 2005/11/30 09:37:53 chriswhite Exp $
inherit kde-functions eutils flag-o-matic
DESCRIPTION="An extremely full-featured mp3/vorbis/cd player with ALSA support, previously called FreeAmp"
HOMEPAGE="http://www.zinf.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-RESTRICT="nomirror"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64 -sparc"
-IUSE="debug esd X gtk oggvorbis gnome arts alsa nls ipv6"
+KEYWORDS="amd64 x86 -sparc"
+IUSE="alsa arts debug esd gnome gtk ipv6 nls vorbis xosd X"
+
+RESTRICT="primaryuri"
RDEPEND=">=dev-libs/glib-2.0.0
+ sys-libs/gdbm
sys-libs/zlib
>=sys-libs/ncurses-5.2
>=media-libs/musicbrainz-1.0.1
- X? ( virtual/x11 )
+ alsa? ( >=media-libs/alsa-lib-0.9.8 )
+ arts? ( kde-base/arts )
esd? ( media-sound/esound )
+ gnome? ( =gnome-base/orbit-0* )
gtk? ( >=x11-libs/gtk+-2.0.0 )
- gnome? ( >=gnome-base/ORBit-0.5.0 )
- oggvorbis? ( media-libs/libvorbis )
- alsa? ( >=media-libs/alsa-lib-0.9.8 )
- arts? ( kde-base/arts )"
+ vorbis? ( media-libs/libvorbis )
+ xosd? ( x11-libs/xosd )
+ X? ( virtual/x11 )"
# When updating next, check boost to see if the newer versions fix compilation
DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )
- nls? ( sys-devel/gettext )
- >=media-libs/id3lib-3.8.0
- dev-libs/boost
dev-db/metakit
- dev-lang/perl"
+ dev-lang/perl
+ dev-libs/boost
+ >=media-libs/id3lib-3.8.0
+ >=sys-devel/automake-1.7
+ nls? ( sys-devel/gettext )
+ x86? ( dev-lang/nasm )"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-cdplay.patch
-}
+ epatch ${FILESDIR}/${P}-configure.patch
-src_compile() {
- local myconf="--enable-cmdline"
+ export WANT_AUTOMAKE=1.7
+ export WANT_AUTOCONF=2.5
+
+ #ebegin "Running aclocal (${WANT_AUTOMAKE})"
+ #aclocal -I m4
+ #eend $?
+ touch aclocal.m4
- myconf="${myconf} `use_enable debug`"
- myconf="${myconf} `use_enable esd`"
- myconf="${myconf} `use_enable arts`"
- myconf="${myconf} `use_enable alsa`"
- myconf="${myconf} `use_enable gnome corba`"
- myconf="${myconf} `use_enable ipv6`"
+ ebegin "Running automake (${WANT_AUTOMAKE})"
+ automake
+ eend $?
- if [ $ARCH == "amd64" ]; then
+ ebegin "Running autoconf (${WANT_AUTOCONF})"
+ autoconf
+ eend $?
+
+ # fix #94149
+ libtoolize --copy --force
+}
+
+src_compile() {
+ if use amd64; then
replace-flags -O? -O
append-flags -frerun-cse-after-loop
fi
@@ -61,15 +77,24 @@ src_compile() {
export ARTSCCONFIG="$KDEDIR/bin/artsc-config"
fi
- econf ${myconf} || die
- make || die
+ econf \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable debug) \
+ $(use_enable esd) \
+ $(use_enable ipv6) \
+ $(use_enable gnome corba) \
+ $(use_enable x86 x86opts) \
+ $(use_enable xosd) \
+ --enable-cmdline || die "configure failed"
+ make || die "make failed"
}
src_install() {
into /usr
dobin base/zinf
- exeinto /usr/lib/zinf/plugins
+ exeinto /usr/$(get_libdir)/zinf/plugins
doexe plugins/*
insinto /usr/share/zinf/themes