summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/seq24')
-rw-r--r--media-sound/seq24/ChangeLog6
-rw-r--r--media-sound/seq24/seq24-0.8.7.ebuild15
2 files changed, 18 insertions, 3 deletions
diff --git a/media-sound/seq24/ChangeLog b/media-sound/seq24/ChangeLog
index a587805f7bc7..fc8600d9c921 100644
--- a/media-sound/seq24/ChangeLog
+++ b/media-sound/seq24/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/seq24
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.30 2008/01/13 14:17:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.31 2008/06/04 13:05:12 aballier Exp $
+
+ 04 Jun 2008; Alexis Ballier <aballier@gentoo.org> seq24-0.8.7.ebuild:
+ Fix build with libsigc++-2.2, thanks to tom <gimpel@sonnenkinder.org>, bug
+ #220827
13 Jan 2008; Alexis Ballier <aballier@gentoo.org> seq24-0.8.7.ebuild:
add missing pkgconfig dep, bug #205599
diff --git a/media-sound/seq24/seq24-0.8.7.ebuild b/media-sound/seq24/seq24-0.8.7.ebuild
index d6dcac25ddf3..2ab0461bff95 100644
--- a/media-sound/seq24/seq24-0.8.7.ebuild
+++ b/media-sound/seq24/seq24-0.8.7.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/seq24-0.8.7.ebuild,v 1.5 2008/01/13 14:17:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/seq24-0.8.7.ebuild,v 1.6 2008/06/04 13:05:12 aballier Exp $
inherit eutils
IUSE="jack lash"
DESCRIPTION="Seq24 is a loop based MIDI sequencer with focus on live performances."
HOMEPAGE="http://www.filter24.org/seq24/"
-SRC_URI="http://www.filter24.org/seq24/${P}.tar.gz"
+SRC_URI="http://www.filter24.org/seq24/${P}.tar.gz
+ mirror://gentoo/${P}-sigc22_fix.patch.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -15,6 +16,7 @@ KEYWORDS="amd64 ~ppc x86"
RDEPEND=">=media-libs/alsa-lib-0.9.0
>=dev-cpp/gtkmm-2.4
+ >=dev-libs/libsigc++-2.0
jack? ( >=media-sound/jack-audio-connection-kit-0.90.0 )
lash? ( >=media-sound/lash-0.5.0 )"
DEPEND="${RDEPEND}
@@ -29,6 +31,15 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fix #220827
+ if has_version ">=dev-libs/libsigc++-2.2"; then
+ epatch "${WORKDIR}/${P}-sigc22_fix.patch"
+ fi
+}
+
src_compile() {
econf \
$(use_enable jack jack-support) \