summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpdscribble/mpdscribble-0.20.ebuild')
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.20.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/media-sound/mpdscribble/mpdscribble-0.20.ebuild b/media-sound/mpdscribble/mpdscribble-0.20.ebuild
deleted file mode 100644
index f8fc182fc5e4..000000000000
--- a/media-sound/mpdscribble/mpdscribble-0.20.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.20.ebuild,v 1.2 2011/05/21 17:34:47 armin76 Exp $
-
-EAPI=2
-WANT_AUTOMAKE="1.11"
-inherit autotools eutils
-
-DESCRIPTION="An MPD client that submits information to Audioscrobbler"
-HOMEPAGE="http://mpd.wikia.com/wiki/Client:Mpdscribble"
-SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-IUSE="+curl"
-
-RDEPEND=">=dev-libs/glib-2.16:2
- media-libs/libmpdclient
- curl? ( net-misc/curl )
- !curl? ( net-libs/libsoup:2.4 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.18-ldadd_gthread.patch
- eautoreconf
-}
-
-src_configure() {
- local myclient=soup
- use curl && myclient=curl
- econf \
- --disable-dependency-tracking \
- --with-http-client=${myclient}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
- chmod 600 "${D}"/etc/mpdscribble.conf
- dodoc AUTHORS NEWS README
- rm -r -f "${D}"/usr/share/doc/${PN}
- dodir /var/cache/mpdscribble
-}