summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog8
-rw-r--r--media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.200609083
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060908.ebuild138
3 files changed, 148 insertions, 1 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index 6a82aa5b2352..9082d7f00379 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.17 2006/08/16 09:42:17 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.18 2006/09/08 19:35:09 zzam Exp $
+
+*vdr-softdevice-0.2.3.20060908 (08 Sep 2006)
+
+ 08 Sep 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +vdr-softdevice-0.2.3.20060908.ebuild:
+ Added new cvs-snapshot. Filter -O2, to get correct colors in OSD.
16 Aug 2006; Matthias Schwarzott <zzam@gentoo.org>
vdr-softdevice-0.2.3.20060814-r1.ebuild:
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060908 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060908
new file mode 100644
index 000000000000..5eb02ab5dda6
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060908
@@ -0,0 +1,3 @@
+MD5 ea2591f80ff5297f46822332cf4e8425 vdr-softdevice-cvs-20060908.tar.bz2 124038
+RMD160 8991e3e0f4f6ea9a8a0171d19098e064c6584c82 vdr-softdevice-cvs-20060908.tar.bz2 124038
+SHA256 f41bfb0dd822ca6c5136fdde842382e72a937bc2acacfeb5430d0e73a5c47f37 vdr-softdevice-cvs-20060908.tar.bz2 124038
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060908.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060908.ebuild
new file mode 100644
index 000000000000..a1bbbe91c68d
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060908.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060908.ebuild,v 1.1 2006/09/08 19:35:09 zzam Exp $
+
+inherit vdr-plugin versionator flag-o-matic
+
+MY_PV="$(get_version_component_range 4)"
+MY_P=${PN}-cvs-${MY_PV}
+
+DESCRIPTION="VDR plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~zzam/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext xinerama"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ x11-libs/libXv
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )"
+
+
+S=${WORKDIR}/${VDRPLUGIN}-cvs-${MY_PV}
+PATCHES="
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+ ${FILESDIR}/softdevice-cvs-xinerama-configure-opts.patch
+ ${FILESDIR}/softdevice-cvs-libcle266mpegdec-0.2.patch"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ einfo "SHM does only support xv at the moment"
+ fi
+ else
+ einfo "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) einfo "SHM support will not be compiled." ;;
+ 1) einfo "SHM support will be compiled." ;;
+ esac
+
+ # Check for ffmpeg relying on libtheora without pkg-config-file
+ # Bug #142250
+ if built_with_use media-video/ffmpeg theora && \
+ has_version "<media-libs/libtheora/libtheora-1.0_alpha4"; then
+
+ eerror "This package will not work when using ffmpeg with"
+ eerror "USE=\"theora\" combined with media-libs/libtheora"
+ eerror "older than version 1.0_alpha4."
+ eerror "Please update to at least media-libs/libtheora-1.0_alpha4."
+ die "Please update to at least media-libs/libtheora-1.0_alpha4."
+ fi
+
+ replace-flags -O* -O0
+}
+
+src_compile() {
+ local MYOPTS=""
+ MYOPTS="${MYOPTS} --disable-vidix"
+ use xv || MYOPTS="${MYOPTS} --disable-xv"
+ use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+ use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+ # MMX-Support
+ # hardcode mmx for amd64 - do not disable even without use-flag
+ if ! use amd64; then
+ use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+ use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+
+ if use !mmx && use !mmxext; then
+ ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
+ ewarn 'Please enable at least one of these two use-flags.'
+ die "${PN}"' does not compile with USE="-mmx -mmxext".'
+ fi
+ fi
+
+ use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"
+
+ [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+ cd ${S}
+ einfo configure ${MYOPTS}
+ ./configure ${MYOPTS} || die "configure failed"
+
+ vdr-plugin_src_compile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ cd ${S}
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsoftdevice-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+
+ insinto /usr/include/vdr-softdevice
+ doins *.h
+}
+