summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-softdevice')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog10
-rw-r--r--media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r23
-rw-r--r--media-plugins/vdr-softdevice/files/rc-addon.sh6
-rw-r--r--media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-shm-contrast.diff17
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r2.ebuild103
5 files changed, 138 insertions, 1 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index 7be307dd6cd8..8a13fd29eab9 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.2 2006/05/11 19:24:58 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.3 2006/05/19 13:53:24 zzam Exp $
+
+*vdr-softdevice-0.2.3.20060511-r2 (19 May 2006)
+
+ 19 May 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-softdevice-0.2.3-shm-contrast.diff, files/rc-addon.sh,
+ +vdr-softdevice-0.2.3.20060511-r2.ebuild:
+ Added useflags mmx and mmxext, See Bug #133698. Add another shm-xv-contrast
+ patch.
*vdr-softdevice-0.2.3.20060511 (11 May 2006)
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r2 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r2
new file mode 100644
index 000000000000..cb395c04db4b
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r2
@@ -0,0 +1,3 @@
+MD5 dfae4ed2ab2bb17572de993461cf36f8 vdr-softdevice-0.2.3a.tgz 133780
+RMD160 d97d7a1bbe4a3b325041bbe0e7ef23740f8121b1 vdr-softdevice-0.2.3a.tgz 133780
+SHA256 bbf05254ce6f0559ce6aeed055272ba6fb207ba443a49926b91506e9de69ab92 vdr-softdevice-0.2.3a.tgz 133780
diff --git a/media-plugins/vdr-softdevice/files/rc-addon.sh b/media-plugins/vdr-softdevice/files/rc-addon.sh
index b0646e4f71d0..ede3fa313f07 100644
--- a/media-plugins/vdr-softdevice/files/rc-addon.sh
+++ b/media-plugins/vdr-softdevice/files/rc-addon.sh
@@ -9,6 +9,12 @@ plugin_pre_vdr_start() {
fi
}
+plugin_pre_vdr_stop() {
+ if [[ ${SOFTDEVICE_VIDEO_OUT} == "shm" ]]; then
+ killall ShmClient
+ fi
+}
+
# for compatibility
if [[ ${SCRIPT_API:-1} -lt 2 ]]; then
plugin_pre_vdr_start
diff --git a/media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-shm-contrast.diff b/media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-shm-contrast.diff
new file mode 100644
index 000000000000..6e5d1b770aca
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-shm-contrast.diff
@@ -0,0 +1,17 @@
+Index: video-xv.c
+===================================================================
+RCS file: /cvsroot/softdevice/softdevice/video-xv.c,v
+retrieving revision 1.54
+diff -u -r1.54 video-xv.c
+--- video-xv.c 24 Apr 2006 22:56:47 -0000 1.54
++++ video-xv.c 15 May 2006 20:32:17 -0000
+@@ -705,7 +705,9 @@
+ PutXvImage();
+ XSync(dpy, False);
+ }
++#ifndef STAND_ALONE
+ attributeStore.CheckVideoParmChange();
++#endif
+ }
+
+ if(cursor_visible == True) {
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r2.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r2.ebuild
new file mode 100644
index 000000000000..429ddb72f6b3
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r2.ebuild,v 1.1 2006/05/19 13:53:24 zzam Exp $
+
+inherit vdr-plugin versionator
+
+MY_PV="$(get_version_component_range 1-3)a"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="VDR plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )"
+
+
+S=${WORKDIR}/${VDRPLUGIN}-${MY_PV}
+PATCHES="${FILESDIR}/${MY_P}-Makefile.diff ${FILESDIR}/${MY_P}-CVS-20060511.diff
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-contrast.diff"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ einfo "SHM does only support xv at the moment"
+ fi
+ else
+ einfo "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) einfo "SHM support will not be compiled." ;;
+ 1) einfo "SHM support will be compiled." ;;
+ esac
+}
+
+disable_in_makefile() {
+ local makefile_define="${1}"
+ sed -i Makefile -e "s-^${makefile_define}-#${makefile_define}-"
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ cd ${S}
+ disable_in_makefile VIDIX_SUPPORT
+ use xv || disable_in_makefile XV_SUPPORT
+ use directfb || disable_in_makefile DFB_SUPPORT
+ use fbcon || disable_in_makefile FB_SUPPORT
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ sed -i Makefile -e 's:^#SHM_SUPPORT:SHM_SUPPORT:'
+ fi
+
+ use mmxext || sed -i Makefile -e '/MMX2$/d'
+ use mmx || sed -i Makefile -e '/MMX$/d'
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsubvdr-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+}
+