summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ming/ChangeLog19
-rw-r--r--media-libs/ming/ming-0.4.3.ebuild119
2 files changed, 131 insertions, 7 deletions
diff --git a/media-libs/ming/ChangeLog b/media-libs/ming/ChangeLog
index 6e78213c2e93..c22cd2d2ae41 100644
--- a/media-libs/ming/ChangeLog
+++ b/media-libs/ming/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for media-libs/ming
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.61 2010/03/14 14:44:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.62 2010/04/20 22:46:52 mabi Exp $
+
+*ming-0.4.3 (20 Apr 2010)
+
+ 20 Apr 2010; <mabi@gentoo.org> +ming-0.4.3.ebuild:
+ new upstream version; also fixes bug #296894, bug #297437
14 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+files/ming-0.4.x-libpng14.patch, ming-0.4.0_rc2.ebuild:
Fix building with libpng14 wrt #309309 by Peter Alfredsen.
- 31 Jan 2010; Raúl Porcel <armin76@gentoo.org> ming-0.4.0_rc2.ebuild:
+ 31 Jan 2010; Raúl Porcel <armin76@gentoo.org> ming-0.4.0_rc2.ebuild:
ia64/s390/sh/sparc stable wrt #297476
23 Jan 2010; Tobias Klausmann <klausman@gentoo.org> ming-0.4.0_rc2.ebuild:
@@ -57,7 +62,7 @@
29 Jul 2008; Jeroen Roovers <jer@gentoo.org> ming-0.3.0-r1.ebuild:
Stable for HPPA (bug #222319).
- 28 Jul 2008; Raúl Porcel <armin76@gentoo.org> ming-0.3.0-r1.ebuild:
+ 28 Jul 2008; Raúl Porcel <armin76@gentoo.org> ming-0.3.0-r1.ebuild:
alpha/ia64/x86 stable wrt #222319
28 Jul 2008; Ferris McCormick <fmccor@gentoo.org> ming-0.3.0-r1.ebuild:
@@ -113,10 +118,10 @@
14 Nov 2007; Jeroen Roovers <jer@gentoo.org> ming-0.2a-r3.ebuild:
Stable for HPPA (bug #198582).
- 11 Nov 2007; Raúl Porcel <armin76@gentoo.org> ming-0.2a-r3.ebuild:
+ 11 Nov 2007; Raúl Porcel <armin76@gentoo.org> ming-0.2a-r3.ebuild:
alpha/ia64/sparc stable wrt #198582
- 11 Nov 2007; Dawid Węgliński <cla@gentoo.org> ming-0.2a-r3.ebuild:
+ 11 Nov 2007; Dawid Węgliński <cla@gentoo.org> ming-0.2a-r3.ebuild:
Stable on x86 (bug #198582)
10 Nov 2007; Markus Rothe <corsair@gentoo.org> ming-0.2a-r3.ebuild:
@@ -147,7 +152,7 @@
20 Aug 2006; Stephanie Lockwood-Childs <wormo@gentoo.org> ming-0.3.0.ebuild:
applying java patch needs to be conditional on java useflag (Bug #144548)
- 20 Aug 2006; Bryan Østergaard <kloeri@gentoo.org> ming-0.3.0.ebuild:
+ 20 Aug 2006; Bryan Østergaard <kloeri@gentoo.org> ming-0.3.0.ebuild:
Fix python dependency.
*ming-0.3.0 (22 Aug 2006)
@@ -164,7 +169,7 @@
Bug #123728, fix python module linking brokenness. Also fix QA issue of
missing SONAME.
- 07 Mar 2006; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ 07 Mar 2006; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
ming-0.2a.ebuild, ming-0.2a-r1.ebuild:
Drop virtual/libc dependency. Add maintainer-needed metadata.
diff --git a/media-libs/ming/ming-0.4.3.ebuild b/media-libs/ming/ming-0.4.3.ebuild
new file mode 100644
index 000000000000..bcf221a518d7
--- /dev/null
+++ b/media-libs/ming/ming-0.4.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ming-0.4.3.ebuild,v 1.1 2010/04/20 22:46:52 mabi Exp $
+
+EAPI=1
+
+PHP_EXT_NAME=ming
+PYTHON_DEPEND="python? 2"
+
+inherit eutils autotools flag-o-matic multilib php-ext-source-r1 perl-module distutils python
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+DESCRIPTION="An Open Source library for Flash movie generation."
+HOMEPAGE="http://ming.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ming/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+perl +python php"
+RDEPEND="perl? ( dev-lang/perl )
+ python? ( virtual/python )
+ media-libs/freetype
+ media-libs/libpng
+ media-libs/giflib
+ sys-libs/zlib
+ !media-libs/libswf"
+DEPEND="${DEPEND}
+ sys-devel/flex"
+
+S=${WORKDIR}/${P/_/.}
+
+#Tests only work when the package is tested on a system
+#which does not presently have any version of ming installed.
+RESTRICT="test"
+RESTRICT_PYTHON_ABIS="3"
+
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #Let's get rid of the TEXTRELS, link dynamic. Use gif.
+ sed -i \
+ -e 's/libming.a/libming.so/' \
+ -e 's/lungif/lgif/' \
+ perl_ext/Makefile.PL
+ sed -i \
+ -e 's/ungif/gif/' \
+ py_ext/setup.py.in
+
+ if use php; then
+ cd "${S}/php_ext"
+ php-ext-source-r1_phpize
+ cd "${S}"
+ fi
+
+ eautoreconf
+}
+
+src_compile() {
+ # build is sensitive to -O3 (bug #297437)
+ replace-flags -O3 -O2
+
+ econf $(use_enable perl) \
+ $(use_enable python) || die "econf failed"
+ emake -j1 DESTDIR="${D}" || die "emake failed"
+
+ if use php; then
+ cd "${S}"/php_ext
+ myconf="--disable-rpath
+ --disable-static
+ --with-ming"
+ php-ext-source-r1_src_compile
+ fi
+}
+
+src_test() {
+ make check || die "tests failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" INSTALLDIRS="vendor" install
+
+ fixlocalpod
+
+ #Get rid of the precompiled stuff, we generate it later.
+ rm -f $(find "${D}" -name '*.pyc')
+
+ if use php; then
+ cd "${S}"/php_ext
+ php-ext-source-r1_src_install
+ fi
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+
+ if use python
+ then
+ ebegin "Compiling ming.py"
+ python_mod_compile $(python_get_sitedir)/ming.py
+ eend $?
+
+ ebegin "Compiling mingc.py"
+ python_mod_compile $(python_get_sitedir)/mingc.py || die "mingc.py failed"
+ eend $?
+ fi
+}
+
+pkg_prerm() {
+ use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+ use python && distutils_pkg_postrm
+}