summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphite2/ChangeLog7
-rw-r--r--media-gfx/graphite2/graphite2-1.1.2.ebuild101
-rw-r--r--media-gfx/graphite2/graphite2-1.1.3.ebuild4
3 files changed, 7 insertions, 105 deletions
diff --git a/media-gfx/graphite2/ChangeLog b/media-gfx/graphite2/ChangeLog
index 3510eee0fd03..7fe09e5bd7c5 100644
--- a/media-gfx/graphite2/ChangeLog
+++ b/media-gfx/graphite2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/graphite2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.31 2012/06/26 20:26:03 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.32 2012/06/29 11:54:55 scarabeus Exp $
+
+ 29 Jun 2012; Tomáš Chvátal <scarabeus@gentoo.org> -graphite2-1.1.2.ebuild,
+ graphite2-1.1.3.ebuild:
+ Stable 1.1.3 on amd64 x86 and ppc. Drop older.
26 Jun 2012; Ian Stakenvicius <axs@gentoo.org> graphite2-1.1.2.ebuild,
graphite2-1.1.3.ebuild:
@@ -145,4 +149,3 @@
26 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org> +graphite2-0.9.4.ebuild,
+metadata.xml:
Add graphite which is optional dependency for libreoffice.
-
diff --git a/media-gfx/graphite2/graphite2-1.1.2.ebuild b/media-gfx/graphite2/graphite2-1.1.2.ebuild
deleted file mode 100644
index 1ea88c38d636..000000000000
--- a/media-gfx/graphite2/graphite2-1.1.2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.1.2.ebuild,v 1.4 2012/06/26 20:26:03 axs Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="test? 2"
-GENTOO_DEPEND_ON_PERL="no"
-inherit base cmake-utils perl-module python
-
-DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
-HOMEPAGE="http://graphite.sil.org/"
-SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="perl test"
-
-RDEPEND="
- perl? ( dev-lang/perl )
-"
-DEPEND="${RDEPEND}
- perl? ( virtual/perl-Module-Build )
- test? (
- dev-libs/glib:2
- media-libs/fontconfig
- media-libs/silgraphite
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.0-includes-libs-perl.patch"
- "${FILESDIR}/${PN}-fix_wrong_linker_opts.patch"
- "${FILESDIR}/${PN}-1.0.2-no_harfbuzz_tests.patch"
- "${FILESDIR}/${PN}-1.0.3-no-test-binaries.patch"
-)
-
-pkg_setup() {
- use perl && perl-module_pkg_setup
- if use test; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- base_src_prepare
-
- # fix perl linking
- if use perl; then
- _check_build_dir init
- sed -i \
- -e "s:@BUILD_DIR@:\"${CMAKE_BUILD_DIR}/src\":" \
- contrib/perl/Build.PL || die
- fi
-
- # make tests optional
- if ! use test; then
- sed -i \
- -e '/tests/d' \
- CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- "-DVM_MACHINE_TYPE=direct"
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use perl; then
- cd contrib/perl
- perl-module_src_prep
- perl-module_src_compile
- fi
-}
-
-src_test() {
- cmake-utils_src_test
- if use perl; then
- cd contrib/perl
- perl-module_src_test
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- if use perl; then
- cd contrib/perl
- perl-module_src_install
- fixlocalpod
- fi
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-
-}
diff --git a/media-gfx/graphite2/graphite2-1.1.3.ebuild b/media-gfx/graphite2/graphite2-1.1.3.ebuild
index a09a8a33b484..90960bf665e5 100644
--- a/media-gfx/graphite2/graphite2-1.1.3.ebuild
+++ b/media-gfx/graphite2/graphite2-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.1.3.ebuild,v 1.2 2012/06/26 20:26:03 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.1.3.ebuild,v 1.3 2012/06/29 11:54:55 scarabeus Exp $
EAPI=4
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
IUSE="perl test"
RDEPEND="