summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gimp/gimp-2.2.9.ebuild')
-rw-r--r--media-gfx/gimp/gimp-2.2.9.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-gfx/gimp/gimp-2.2.9.ebuild b/media-gfx/gimp/gimp-2.2.9.ebuild
index 649409c20af1..157701ba3041 100644
--- a/media-gfx/gimp/gimp-2.2.9.ebuild
+++ b/media-gfx/gimp/gimp-2.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.2.9.ebuild,v 1.1 2005/10/28 00:46:29 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.2.9.ebuild,v 1.1.1.1 2005/11/30 09:37:44 chriswhite Exp $
inherit flag-o-matic libtool eutils fdo-mime alternatives
@@ -77,7 +77,9 @@ src_compile() {
# only use mmx if hardened is not set
local USE_MMX=
- replace-flags "-march=k6*" "-march=i586"
+ # remove this for now, since I have 3 reports that this is
+ # not necessary
+ # replace-flags "-march=k6*" "-march=i586"
# gimp uses inline functions (plug-ins/common/grid.c) (#23078)
# gimp uses floating point math, needs accuracy (#98685)
@@ -158,7 +160,8 @@ pkg_postinst() {
alternatives_auto_makesym "/usr/bin/gimp" "/usr/bin/gimp-[0-9].[0-9]"
# fix for bug #76050
- ln -s $(gimptool-2.0 --gimpdatadir)/images/wilber-icon.png /usr/share/pixmaps/
+ ln -s $(gimptool-2.0 --gimpdatadir)/images/wilber-icon.png \
+ ${ROOT}/usr/share/pixmaps/
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
@@ -168,7 +171,8 @@ pkg_postinst() {
}
pkg_postrm() {
- rm /usr/share/pixmaps/wilber-icon.png
+ [[ ! -f ${ROOT}/usr/bin/gimp-2.2 ]] && \
+ rm -f ${ROOT}/usr/share/pixmaps/wilber-icon.png
fdo-mime_desktop_database_update
fdo-mime_mime_database_update