summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mailody/ChangeLog9
-rw-r--r--mail-client/mailody/files/digest-mailody-0.4.03
-rw-r--r--mail-client/mailody/files/digest-mailody-0.4.0_rc13
-rw-r--r--mail-client/mailody/files/digest-mailody-0.4.0_rc23
-rw-r--r--mail-client/mailody/files/mailody-0.4.0_rc1-fix-parsing.patch52
-rw-r--r--mail-client/mailody/mailody-0.4.0.ebuild (renamed from mail-client/mailody/mailody-0.4.0_rc2.ebuild)2
-rw-r--r--mail-client/mailody/mailody-0.4.0_rc1.ebuild25
7 files changed, 12 insertions, 85 deletions
diff --git a/mail-client/mailody/ChangeLog b/mail-client/mailody/ChangeLog
index b19d95c520d8..0cc453729c4e 100644
--- a/mail-client/mailody/ChangeLog
+++ b/mail-client/mailody/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/mailody
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mailody/ChangeLog,v 1.7 2007/01/27 18:54:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailody/ChangeLog,v 1.8 2007/02/04 01:39:03 flameeyes Exp $
+
+*mailody-0.4.0 (04 Feb 2007)
+
+ 04 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
+ -files/mailody-0.4.0_rc1-fix-parsing.patch, -mailody-0.4.0_rc1.ebuild,
+ -mailody-0.4.0_rc2.ebuild, +mailody-0.4.0.ebuild:
+ Version bump and remove rcs.
*mailody-0.4.0_rc2 (27 Jan 2007)
diff --git a/mail-client/mailody/files/digest-mailody-0.4.0 b/mail-client/mailody/files/digest-mailody-0.4.0
new file mode 100644
index 000000000000..bebbdfd2ace2
--- /dev/null
+++ b/mail-client/mailody/files/digest-mailody-0.4.0
@@ -0,0 +1,3 @@
+MD5 77e81989175907c6916cd2e271d281b9 mailody-0.4.0.tar.bz2 672921
+RMD160 fa92135db27917f384755d00cb6c682d5a8eb397 mailody-0.4.0.tar.bz2 672921
+SHA256 f1635fddd45b9a2d18284b85495571b4d3fe12b11774f7534566cab67e644eaa mailody-0.4.0.tar.bz2 672921
diff --git a/mail-client/mailody/files/digest-mailody-0.4.0_rc1 b/mail-client/mailody/files/digest-mailody-0.4.0_rc1
deleted file mode 100644
index 8adc77f09f0e..000000000000
--- a/mail-client/mailody/files/digest-mailody-0.4.0_rc1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 f673e26057a4c748589da6a0265f8ee4 mailody-0.4.0-rc1.tar.bz2 688371
-RMD160 c6aad5bc8e01d4c5b7c9065d2cd4a2795f949a81 mailody-0.4.0-rc1.tar.bz2 688371
-SHA256 056e15161a51949f73b5b456aebc1664ef2f67f5755cd7b18cf3c963287a7abc mailody-0.4.0-rc1.tar.bz2 688371
diff --git a/mail-client/mailody/files/digest-mailody-0.4.0_rc2 b/mail-client/mailody/files/digest-mailody-0.4.0_rc2
deleted file mode 100644
index 4ea25a6eb8dc..000000000000
--- a/mail-client/mailody/files/digest-mailody-0.4.0_rc2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 f79413d524dbb8c0474510081bc1d3d2 mailody-0.4.0-rc2.tar.bz2 692338
-RMD160 6376dc8086fd5f24ef5a52a16a6847e156f8be9a mailody-0.4.0-rc2.tar.bz2 692338
-SHA256 fb56bd72c9155e9b42946fdffc11932d3866d776afb9cfe8de451ebadf690342 mailody-0.4.0-rc2.tar.bz2 692338
diff --git a/mail-client/mailody/files/mailody-0.4.0_rc1-fix-parsing.patch b/mail-client/mailody/files/mailody-0.4.0_rc1-fix-parsing.patch
deleted file mode 100644
index d40a79e75c2c..000000000000
--- a/mail-client/mailody/files/mailody-0.4.0_rc1-fix-parsing.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Index: src/messagedata.cpp
-===================================================================
---- mailody/src/messagedata.cpp (revision 626296)
-+++ mailody/src/messagedata.cpp (revision 626297)
-@@ -114,19 +114,19 @@
- // a case sensitive compare.
- QString line = (*it).lower().stripWhiteSpace();
-
-- if (line.startsWith("size"))
-- m_size = (*it).section(' ',1).stripWhiteSpace().toInt();
-+ if (line.startsWith("size:"))
-+ m_size = (*it).section(':',1).stripWhiteSpace().toInt();
-
- else if (line.startsWith("subject"))
- {
- const char* usedCS;
-- QString t = (*it).section(' ',1).stripWhiteSpace();
-+ QString t = (*it).section(':',1).stripWhiteSpace();
- m_subject =
- KMime::decodeRFC2047String(t.local8Bit(), &usedCS, "", false);
- }
-- else if (line.startsWith("from"))
-+ else if (line.startsWith("from:"))
- {
-- QString t = (*it).section(' ',1).stripWhiteSpace();
-+ QString t = (*it).section(':',1).stripWhiteSpace();
- const char* usedCS;
- t = KMime::decodeRFC2047String(t.local8Bit(), &usedCS, "", false);
- if (Global::myEmail(t))
-@@ -134,11 +134,11 @@
- m_sender = t;
- parseEmail(m_sender);
- }
-- else if (m_sender.isEmpty() && line.startsWith("to"))
-+ else if (m_sender.isEmpty() && line.startsWith("to:"))
- {
- // If there is no From address use the To address...
- const char* usedCS;
-- QString t = (*it).section(' ',1).stripWhiteSpace();
-+ QString t = (*it).section(':',1).stripWhiteSpace();
- m_sender =
- KMime::decodeRFC2047String(t.local8Bit(), &usedCS, "", false);
- parseEmail(m_sender);
-@@ -428,7 +428,7 @@
- }
-
- // Maybe there is a: toma <toma@omat.nl>
-- else if ((start=email.find("<"))!=-1)
-+ else if ((start=email.find("<"))!=-1 && start > 2)
- {
- email = email.mid(0,start);
- return;
diff --git a/mail-client/mailody/mailody-0.4.0_rc2.ebuild b/mail-client/mailody/mailody-0.4.0.ebuild
index 2ffefea74e9a..3a54c499cc85 100644
--- a/mail-client/mailody/mailody-0.4.0_rc2.ebuild
+++ b/mail-client/mailody/mailody-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mailody/mailody-0.4.0_rc2.ebuild,v 1.1 2007/01/27 18:54:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailody/mailody-0.4.0.ebuild,v 1.1 2007/02/04 01:39:04 flameeyes Exp $
inherit kde
diff --git a/mail-client/mailody/mailody-0.4.0_rc1.ebuild b/mail-client/mailody/mailody-0.4.0_rc1.ebuild
deleted file mode 100644
index e7bb8fae4933..000000000000
--- a/mail-client/mailody/mailody-0.4.0_rc1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mailody/mailody-0.4.0_rc1.ebuild,v 1.2 2007/01/22 19:53:19 flameeyes Exp $
-
-inherit kde
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="IMAP mail client for KDE"
-HOMEPAGE="http://www.mailody.net"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="=dev-db/sqlite-3*
- app-crypt/qca-tls"
-
-S="${WORKDIR}/${MY_P}"
-
-need-kde 3.5
-
-PATCHES="${FILESDIR}/${P}-fix-parsing.patch"