summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kgamma/kgamma-4.6.4.ebuild')
-rw-r--r--kde-base/kgamma/kgamma-4.6.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/kgamma/kgamma-4.6.4.ebuild b/kde-base/kgamma/kgamma-4.6.4.ebuild
new file mode 100644
index 000000000000..b164140a5999
--- /dev/null
+++ b/kde-base/kgamma/kgamma-4.6.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kgamma/kgamma-4.6.4.ebuild,v 1.1 2011/06/10 18:00:11 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdegraphics"
+ kde_eclass="kde4-meta"
+fi
+
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE screen gamma values kcontrol module"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ x11-libs/libXxf86vm
+"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA_NOFATAL+=" doc/kcontrol/kgamma"
+ fi
+
+ ${kde_eclass}_src_unpack
+}
+
+if [[ ${PV} != *9999 ]]; then
+src_install() {
+ kde4-meta_src_install
+
+ # why, oh why?!
+ rm "${ED}/usr/share/apps/cmake/modules/FindKSane.cmake" || die
+}
+fi