summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.6.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 73bbaaf562ff..1990d40561c7 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.201 2011/07/06 20:05:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.202 2011/07/09 15:14:14 alexxy Exp $
+
+*kate-4.6.5 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.6.5.ebuild:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> -kate-4.6.2.ebuild:
Drop KDE 4.6.2
diff --git a/kde-base/kate/kate-4.6.5.ebuild b/kde-base/kate/kate-4.6.5.ebuild
new file mode 100644
index 000000000000..882fd8881b00
--- /dev/null
+++ b/kde-base/kate/kate-4.6.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.6.5.ebuild,v 1.1 2011/07/09 15:14:14 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}