summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.5.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 39c5cfc519d8..2ea94e0430dd 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.85 2010/09/05 23:13:21 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.86 2010/10/06 09:17:15 alexxy Exp $
+
+*dolphin-4.5.2 (05 Oct 2010)
+
+ 05 Oct 2010; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.5.2.ebuild:
+ Version bump KDE SC 4.5.2
05 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
dolphin-4.5.1.ebuild:
diff --git a/kde-base/dolphin/dolphin-4.5.2.ebuild b/kde-base/dolphin/dolphin-4.5.2.ebuild
new file mode 100644
index 000000000000..acccdf3035fc
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.5.2.ebuild,v 1.1 2010/10/06 09:17:15 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}