summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/baloo/baloo-4.14.0.ebuild')
-rw-r--r--kde-base/baloo/baloo-4.14.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-base/baloo/baloo-4.14.0.ebuild b/kde-base/baloo/baloo-4.14.0.ebuild
new file mode 100644
index 000000000000..45b0442c0f0d
--- /dev/null
+++ b/kde-base/baloo/baloo-4.14.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/baloo/baloo-4.14.0.ebuild,v 1.1 2014/08/20 16:02:52 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Next generation of the Nepomuk project"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug minimal"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kfilemetadata)
+ dev-libs/qjson
+ =dev-libs/xapian-1.2*[chert]
+ sys-apps/attr
+ !<kde-base/nepomuk-4.12.50
+"
+RDEPEND="
+ ${DEPEND}
+"
+RESTRICT="test"
+
+src_install() {
+ kde4-base_src_install
+
+ if use minimal ; then
+ rm "${D}"/usr/bin/baloo*
+ rm -r "${D}"/usr/share/dbus-1
+ rm -r "${D}"/usr/share/icons
+ rm -r "${D}"/usr/share/polkit-1
+ fi
+}