summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/zangband')
-rw-r--r--games-roguelike/zangband/ChangeLog36
-rw-r--r--games-roguelike/zangband/Manifest3
-rw-r--r--games-roguelike/zangband/files/digest-zangband-2.7.31
-rw-r--r--games-roguelike/zangband/zangband-2.7.3.ebuild56
4 files changed, 96 insertions, 0 deletions
diff --git a/games-roguelike/zangband/ChangeLog b/games-roguelike/zangband/ChangeLog
new file mode 100644
index 000000000000..52139ec2e624
--- /dev/null
+++ b/games-roguelike/zangband/ChangeLog
@@ -0,0 +1,36 @@
+# ChangeLog for app-games/zangband
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/zangband/ChangeLog,v 1.1 2003/09/10 04:59:58 vapier Exp $
+
+ 10 Jun 2003; <msterret@gentoo.org> zangband-2.7.3.ebuild:
+ DEPEND on sed >= 4
+
+*zangband-2.7.3 (18 May 2003)
+
+ 18 May 2003; Martin Holzer <mholzer@gentoo.org> zangband-2.7.3.ebuild:
+ Version bumped. Ebuild submitted by Frank Straetz <Frank@KTHXBYE.de>
+ in #20994.
+
+*zangband-2.7.2 (16 Mar 2003)
+
+ 16 Mar 2003; José Alberto Suárez López <bass@gentoo.org> zangband-2.7.2.ebuild:
+ bumped version and use game.eclass
+
+*zangband-2.7.1 (15 Jul 2002)
+
+ 07 Sep 2002; J. Alberto S. L. <bass@gentoo.org>
+ zangband-2.7.1.ebuild:
+ Fix problem with PORTAGE_TMPDIR #7292
+
+ 6 Sep 2002; Owen Stampflee <owen@gentoo.org> :
+ Changed "PPC" in keywords, to "ppc".
+
+ 22 Aug 2002; J. Alberto S. L. <bass@gentoo.org> zangband-2.7.1.ebuild:
+ Added PPC KEYWORD.
+
+ Added "ZAngband remember its highscores by touching the file in a
+ more gentle way" by nikai@nikai.net (Nicolas Kaiser)
+
+ 15 Jul 2002; J. Alberto S. L. <bass@gentoo.org> zangband-2.7.1.ebuild:
+ First relase
+
diff --git a/games-roguelike/zangband/Manifest b/games-roguelike/zangband/Manifest
new file mode 100644
index 000000000000..b52589bf42e7
--- /dev/null
+++ b/games-roguelike/zangband/Manifest
@@ -0,0 +1,3 @@
+MD5 4eb90a8a0e205c79269fc8900e12ccf7 ChangeLog 1187
+MD5 3cf5421538bd68513c2634206b0a41a1 zangband-2.7.3.ebuild 1658
+MD5 1a295dc9c335ddfe6e7b11b575204879 files/digest-zangband-2.7.3 67
diff --git a/games-roguelike/zangband/files/digest-zangband-2.7.3 b/games-roguelike/zangband/files/digest-zangband-2.7.3
new file mode 100644
index 000000000000..348f1d6af640
--- /dev/null
+++ b/games-roguelike/zangband/files/digest-zangband-2.7.3
@@ -0,0 +1 @@
+MD5 f3d7f74aec7d04412ea8442603458815 zangband-2.7.3.tar.gz 2723509
diff --git a/games-roguelike/zangband/zangband-2.7.3.ebuild b/games-roguelike/zangband/zangband-2.7.3.ebuild
new file mode 100644
index 000000000000..c9fe82072770
--- /dev/null
+++ b/games-roguelike/zangband/zangband-2.7.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/zangband/zangband-2.7.3.ebuild,v 1.1 2003/09/10 04:59:58 vapier Exp $
+
+inherit games
+
+DESCRIPTION="An enhanced version of the Roguelike game Angband"
+HOMEPAGE="http://www.zangband.org/"
+SRC_URI="ftp://clockwork.dementia.org/angband/Variant/ZAngband/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Moria GPL-2"
+KEYWORDS="x86 ppc"
+IUSE="X"
+
+DEPEND=">=sys-libs/ncurses-5
+ >=sys-apps/sed-4
+ X? ( >=x11-base/xfree-4.0 )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # Version 2.7.3 won't configure without this
+ export WANT_AUTOCONF_2_5=1
+
+ local myconf="--with-setgid=${GAMES_GROUP}"
+ use X || myconf="${myconf} --without-x"
+
+ # Bootstrap and configure Zangband
+ ./bootstrap || die "bootstrapping failed"
+ egamesconf ${myconf} || die
+
+ # This fixes the games/games bug
+ sed -i "s:${GAMES_DATADIR}:/usr/share:" makefile
+ emake || die
+}
+
+src_install() {
+ # Keep some important dirs we want to chmod later
+ keepdir ${GAMES_DATADIR}/zangband/lib/apex
+ keepdir ${GAMES_DATADIR}/zangband/lib/user
+ keepdir ${GAMES_DATADIR}/zangband/lib/save
+
+ # Install the basic files but remove unneeded crap
+ make DESTDIR=${D}/${GAMES_DATADIR}/zangband/ installbase || die
+ rm ${D}/${GAMES_DATADIR}/zangband/{angdos.cfg,readme,z_faq.txt,z_update.txt}
+
+ # Install everything else and fix the permissions
+ exeinto /usr/games/bin
+ doexe zangband
+ dodoc readme z_faq.txt z_update.txt
+
+ prepgamesdirs
+ # All users in the games group need write permissions to some important dirs
+ chmod -R g+w ${D}/${GAMES_DATADIR}/zangband/lib/{apex,save,user}
+}