summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/mcl/mcl-0.52.99.ebuild')
-rw-r--r--games-mud/mcl/mcl-0.52.99.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-mud/mcl/mcl-0.52.99.ebuild b/games-mud/mcl/mcl-0.52.99.ebuild
new file mode 100644
index 000000000000..a00a903624ce
--- /dev/null
+++ b/games-mud/mcl/mcl-0.52.99.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.52.99.ebuild,v 1.1 2003/09/10 19:03:12 vapier Exp $
+
+IUSE="python perl"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A console MUD client scriptable in Perl and Python"
+SRC_URI="http://www.andreasen.org/mcl/dist/${P}-src.tar.gz"
+HOMEPAGE="http://www.andreasen.org/mcl/"
+LICENSE="GPL-2"
+DEPEND="perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+KEYWORDS="x86"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use perl && myconf="${myconf} --enable-perl" || myconf="${myconf} --disable-perl"
+ use python && myconf="${myconf} --enable-python" || myconf="${myconf} --disable-python"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man $myconf || die "./configure failed"
+
+ patch -p0<${FILESDIR}/mcl-0.52.99-gcc3.patch
+
+ emake || die
+}
+
+src_install () {
+ make INSTALL_ROOT=${D} install || die
+
+ dodoc doc/*
+}