summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2003/ChangeLog5
-rw-r--r--games-fps/ut2003/ut2003-2225-r1.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/games-fps/ut2003/ChangeLog b/games-fps/ut2003/ChangeLog
index 8401c9231c1c..215722fe8d9f 100644
--- a/games-fps/ut2003/ChangeLog
+++ b/games-fps/ut2003/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/ut2003
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.14 2004/03/16 19:26:41 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.15 2004/03/19 18:33:05 wolf31o2 Exp $
+
+ 19 Mar 2004; Chris Gianelloni <wolf31o2@gentoo.org> ut2003-2225-r1.ebuild:
+ Fixing sed problem and (hopefully) closing bug #35603.
16 Mar 2004; Chris Gianelloni <wolf31o2@gentoo.org> ut2003-2225-r1.ebuild:
Changed sed lines to use sed -i.
diff --git a/games-fps/ut2003/ut2003-2225-r1.ebuild b/games-fps/ut2003/ut2003-2225-r1.ebuild
index 5a0fda0cdb8e..12175891fc65 100644
--- a/games-fps/ut2003/ut2003-2225-r1.ebuild
+++ b/games-fps/ut2003/ut2003-2225-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ut2003-2225-r1.ebuild,v 1.4 2004/03/16 19:26:41 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ut2003-2225-r1.ebuild,v 1.5 2004/03/19 18:33:05 wolf31o2 Exp $
inherit games
@@ -110,16 +110,14 @@ src_install() {
insinto ${dir}
doins ${S}/README.linux ${S}/Unreal.xpm || die "copying readme/icon"
- #sed -e "s:GENTOO_DIR:${dir}:" ${FILESDIR}/ucc > ucc
- sed -e -i "s:GENTOO_DIR:${dir}:" ${FILESDIR}/ut2003
- #dogamesbin ucc ut2003
+ sed -i "s:GENTOO_DIR:${dir}:" ${FILESDIR}/ut2003
dogamesbin ut2003
rm ${Ddir}/System/{UT2003,User}.ini || die "deleting ini files"
# this brings our install up to the newest version
cd ${S}
- bin/Linux/x86/loki_patch --verify patch.dat
+ bin/Linux/x86/loki_patch --verify patch.dat || die "verifying patch"
bin/Linux/x86/loki_patch patch.dat ${Ddir} >& /dev/null || die "patching"
# now, since these files are coming off a cd, the times/sizes/md5sums wont