summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/xmame')
-rw-r--r--games-emulation/xmame/files/0.78.1-osd_die.patch17
-rw-r--r--games-emulation/xmame/xmame-0.78.1.ebuild5
2 files changed, 20 insertions, 2 deletions
diff --git a/games-emulation/xmame/files/0.78.1-osd_die.patch b/games-emulation/xmame/files/0.78.1-osd_die.patch
new file mode 100644
index 000000000000..c664052108a1
--- /dev/null
+++ b/games-emulation/xmame/files/0.78.1-osd_die.patch
@@ -0,0 +1,17 @@
+--- ./src/cpu/z80/z80.c.orig 2004-01-28 12:52:51.340762752 -0500
++++ ./src/cpu/z80/z80.c 2004-01-28 12:53:35.817001336 -0500
+@@ -3991,6 +3991,14 @@
+ /****************************************************************************
+ * Processor initialization
+ ****************************************************************************/
++void CLIB_DECL osd_die(const char *text,...)
++{
++va_list va;
++va_start(va, text);
++vprintf(text, va);
++va_end(va);
++exit(1);
++}
+ void z80_init(void)
+ {
+ int cpu = cpu_getactivecpu();
diff --git a/games-emulation/xmame/xmame-0.78.1.ebuild b/games-emulation/xmame/xmame-0.78.1.ebuild
index d694483f34f4..56e3414b770e 100644
--- a/games-emulation/xmame/xmame-0.78.1.ebuild
+++ b/games-emulation/xmame/xmame-0.78.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.78.1.ebuild,v 1.1 2004/01/14 21:40:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.78.1.ebuild,v 1.2 2004/01/28 22:36:38 vapier Exp $
inherit games flag-o-matic gcc eutils
@@ -12,7 +12,7 @@ SRC_URI="http://x.mame.net/download/xmame-${PV}.tar.bz2"
LICENSE="xmame"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~ia64 ~amd64"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha hppa ~ia64 ~amd64"
IUSE="sdl dga xv alsa esd opengl X 3dfx svga ggi arts joystick icc net"
RDEPEND="sys-libs/zlib
@@ -36,6 +36,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-glx-fix.patch
+ epatch ${FILESDIR}/${PV}-osd_die.patch
sed -i 's:JOY_BUTTONS 16:JOY_BUTTONS 32:' src/unix/devices.h || die "setting joybuttons failed" #36818
#ln -s makefile.unix Makefile