summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/gltron')
-rw-r--r--games-action/gltron/ChangeLog6
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/games-action/gltron/ChangeLog b/games-action/gltron/ChangeLog
index adad888535d5..3970c34ea15b 100644
--- a/games-action/gltron/ChangeLog
+++ b/games-action/gltron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/gltron
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.14 2010/04/14 16:13:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.15 2010/08/24 03:49:06 mr_bones_ Exp $
+
+ 24 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ gltron-0.70-r1.ebuild:
+ respect LDFLAGS (bug #332473)
14 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
gltron-0.70-r1.ebuild:
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
index d0fa4ecf8bda..175074e50b94 100644
--- a/games-action/gltron/gltron-0.70-r1.ebuild
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.6 2010/04/14 16:13:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.7 2010/08/24 03:49:06 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -28,6 +28,10 @@ src_prepare() {
"${FILESDIR}"/${P}-configure.patch \
"${FILESDIR}"/${P}-prototypes.patch \
"${FILESDIR}"/${P}-debian.patch
+ sed -i \
+ -e '/^gltron_LINK/s/$/ $(LDFLAGS)/' \
+ Makefile.in \
+ || die 'sed failed'
}
src_configure() {