summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/darcs/darcs-1.0.6.ebuild')
-rw-r--r--dev-vcs/darcs/darcs-1.0.6.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/darcs/darcs-1.0.6.ebuild b/dev-vcs/darcs/darcs-1.0.6.ebuild
new file mode 100644
index 000000000000..71e0f11d3a2e
--- /dev/null
+++ b/dev-vcs/darcs/darcs-1.0.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/darcs-1.0.6.ebuild,v 1.1 2010/03/14 12:29:26 kolmodin Exp $
+
+inherit base eutils
+
+DESCRIPTION="David's Advanced Revision Control System is yet another replacement for CVS"
+HOMEPAGE="http://abridgegame.org/darcs"
+MY_P0="${P/_rc/rc}"
+MY_P="${MY_P0/_pre/pre}"
+SRC_URI="http://abridgegame.org/darcs/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+# disabled wxwindows use flag for now, as I got build errors
+
+DEPEND=">=net-misc/curl-7.10.2
+ virtual/mta
+ <dev-lang/ghc-6.6
+ doc? ( virtual/latex-base
+ dev-tex/latex2html )"
+# wxwindows? ( dev-haskell/wxhaskell )
+
+RDEPEND=">=net-misc/curl-7.10.2
+ virtual/mta
+ dev-libs/gmp"
+# wxwindows? ( dev-haskell/wxhaskell )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use doc && ! built_with_use -o dev-tex/latex2html png gif; then
+ eerror "Building darcs with USE=\"doc\" requires that"
+ eerror "dev-tex/latex2html is built with at least one of"
+ eerror "USE=\"png\" and USE=\"gif\"."
+ die "USE=doc requires dev-tex/latex2html with USE=\"png\" or USE=\"gif\""
+ fi
+}
+
+src_unpack() {
+ base_src_unpack
+
+ # If we're going to use the CFLAGS with GHC's -optc flag then we'd better
+ # use it with -opta too or it'll break with some CFLAGS, eg -mcpu on sparc
+ sed -i 's:\($(addprefix -optc,$(CFLAGS))\):\1 $(addprefix -opta,$(CFLAGS)):' \
+ "${S}/autoconf.mk.in"
+
+ # On ia64 we need to tone down the level of inlining so we don't break some
+ # of the low level ghc/gcc interaction gubbins.
+ use ia64 && sed -i 's/-funfolding-use-threshold20//' "${S}/GNUmakefile"
+}
+
+src_compile() {
+ local myconf
+# myconf="`use_with wxwindows wx`"
+ # distribution contains garbage files
+ make clean || die "make clean failed"
+ if use doc ; then
+ sed -i "s:/doc:/doc/${PF}:" GNUmakefile
+ else
+ sed -i \
+ -e 's: installdocs::' \
+ -e 's:^.*BUILDDOC.*yes.*$::' \
+ -e 's/^.*TARGETS.*\(darcs\.ps\|manual\).*$/:/' \
+ configure
+ fi
+ econf ${myconf} || die "configure failed"
+ echo 'INSTALLWHAT=installbin' >> autoconf.mk
+ make all || die "make failed"
+}
+
+src_test() {
+ make test
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "installation failed"
+}