summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mono-tools/ChangeLog12
-rw-r--r--dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch117
-rw-r--r--dev-util/mono-tools/mono-tools-2.4.2-r1.ebuild (renamed from dev-util/mono-tools/mono-tools-2.4.2.ebuild)28
-rw-r--r--dev-util/mono-tools/mono-tools-2.4.9999.ebuild28
-rw-r--r--dev-util/mono-tools/mono-tools-9999.ebuild28
5 files changed, 179 insertions, 34 deletions
diff --git a/dev-util/mono-tools/ChangeLog b/dev-util/mono-tools/ChangeLog
index 113c2bd44ae5..9a0a307eb3ec 100644
--- a/dev-util/mono-tools/ChangeLog
+++ b/dev-util/mono-tools/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-util/mono-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/ChangeLog,v 1.61 2009/06/30 06:02:08 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/ChangeLog,v 1.62 2009/09/02 14:05:04 loki_val Exp $
+
+*mono-tools-2.4.2-r1 (02 Sep 2009)
+
+ 02 Sep 2009; Peter Alfredsen <loki_val@gentoo.org>
+ -mono-tools-2.4.2.ebuild, +mono-tools-2.4.2-r1.ebuild,
+ mono-tools-2.4.9999.ebuild,
+ +files/mono-tools-2.4-html-renderer-fixes.patch, mono-tools-9999.ebuild:
+ Fix html-renderer-fixes patch to make Mono.Webbrowser engine optional.
+ Xulrunner use-flag now pulls in gluezilla for Mono.Webbrowser. Drop
+ gecko-sharp usage, since it's broken. Update 9999 ebuilds with same fixes.
*mono-tools-2.4.2 (30 Jun 2009)
diff --git a/dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch b/dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch
new file mode 100644
index 000000000000..cb420dccc687
--- /dev/null
+++ b/dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch
@@ -0,0 +1,117 @@
+diff -NrU5 mono-tools-2.4.2.orig/configure.in mono-tools-2.4.2/configure.in
+--- mono-tools-2.4.2.orig/configure.in 2009-09-02 13:49:47.000000000 +0200
++++ mono-tools-2.4.2/configure.in 2009-09-02 14:14:04.000000000 +0200
+@@ -43,54 +43,84 @@
+
+ PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 glade-sharp-2.0 gnome-sharp-2.0 gconf-sharp-2.0)
+ #PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp glade-sharp gconf-sharp)
+ AC_SUBST(GTK_SHARP_LIBS)
+
+-PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-3.14, enable_gtkhtml=yes, enable_gtkhtml=no)
+-if test "x$enable_gtkhtml" = "xyes"; then
+-CSHARP_FLAGS="-d:GTKHTML_SHARP_3_14"
+-else
+-PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-2.0, enable_gtkhtml=yes, enable_gtkhtml=no)
+-CSHARP_FLAGS=
++AC_ARG_ENABLE(gtkhtml,
++ AC_HELP_STRING([--enable-gtkhtml], [Use GTKHTML Browser]),,
++ enable_gtkhtml=yes)
++
++if test "x$enable_gtkhtml" = "xyes" ; then
++ PKG_CHECK_MODULES([GTKHTML_SHARP],
++ [gtkhtml-sharp-3.14],
++ [CSHARP_FLAGS="-d:GTKHTML_SHARP_3_14"],
++ [
++ PKG_CHECK_MODULES([GTKHTML_SHARP],
++ [gtkhtml-sharp-2.0],
++ [CSHARP_FLAGS=""],
++ [])
++ ]
++ )
++ AC_SUBST(GTKHTML_SHARP_LIBS)
++ AC_SUBST(CSHARP_FLAGS)
+ fi
+-AC_SUBST(GTKHTML_SHARP_LIBS)
+-AC_SUBST(CSHARP_FLAGS)
++
+ AM_CONDITIONAL(ENABLE_GTKHTML, test "x$enable_gtkhtml" = "xyes")
+
+-PKG_CHECK_MODULES(GECKO_SHARP, gecko-sharp-2.0, enable_gecko=yes, enable_gecko=no)
+-AC_SUBST(GECKO_SHARP_LIBS)
++AC_ARG_ENABLE(gecko,
++ AC_HELP_STRING([--enable-gecko], [Use Gecko / Xulrunner-1.8 browser libs]),,
++ enable_gecko=yes)
++
++if test "x$enable_gecko" = "xyes" ; then
++ PKG_CHECK_MODULES(GECKO_SHARP, gecko-sharp-2.0)
++
++ AC_SUBST(GECKO_SHARP_LIBS)
++
++ # get the mozilla home directory
++ MOZILLA_HOME="`$PKG_CONFIG --variable=libdir mozilla-gtkmozembed`"
++ AC_SUBST(MOZILLA_HOME)
++fi
++
+ AM_CONDITIONAL(ENABLE_GECKO, test "x$enable_gecko" = "xyes")
+
+-if test "x$enable_gecko" = "xyes"; then
+- # get the mozilla home directory
+- MOZILLA_HOME="`$PKG_CONFIG --variable=libdir mozilla-gtkmozembed`"
+- AC_SUBST(MOZILLA_HOME)
++AC_ARG_ENABLE(webkit,
++ AC_HELP_STRING([--enable-webkit], [Use Webkit browser]),,
++ enable_webkit=yes)
++
++if test "x$enable_webkit" = "xyes" ; then
++ PKG_CHECK_MODULES(WEBKIT_SHARP, webkit-sharp-1.0)
++ AC_SUBST(WEBKIT_SHARP_LIBS)
+ fi
+
+-PKG_CHECK_MODULES(WEBKIT_SHARP, webkit-sharp-1.0, enable_webkit=yes, enable_webkit=no)
+-AC_SUBST(WEBKIT_SHARP_LIBS)
+ AM_CONDITIONAL(ENABLE_WEBKIT, test "x$enable_webkit" = "xyes")
+
+ # PKG_CHECK_MODULES(MONOWEBBROWSER, mono-webbrowser, enable_monowebbrowser=yes, enable_monowebbrowser=no)
+ # AC_SUBST(MONOWEBBROWSER_LIBS)
+
+-AC_MSG_CHECKING([for Mono.WebBrowser])
+-if test "x$GACUTIL" = "xno"
+-then
+- AC_MSG_RESULT([no])
+- if test "x$enable_monowebbrowser" = "x" ; then enable_monowebbrowser=no ; fi
+-else
+- if $GACUTIL -l Mono.WebBrowser | grep -q "Mono.WebBrowser"
++AC_ARG_ENABLE(monowebbrowser,
++ AC_HELP_STRING([--enable-monowebbrowser], [Use Mono.Webbrowser]),,
++ enable_monowebbrowser=yes)
++
++if test "x$enable_monowebbrowser" = "xyes" ; then
++ AC_MSG_CHECKING([for Mono.WebBrowser])
++ if test "x$GACUTIL" = "xno"
+ then
+- AC_MSG_RESULT([yes])
+- enable_monowebbrowser=yes
++ AC_MSG_RESULT([no])
++ if test "x$enable_monowebbrowser" = "x" ; then enable_monowebbrowser=no ; fi
+ else
+- AC_MSG_RESULT([no])
+- enable_monowebbrowser=no
+- fi
++ if $GACUTIL -l Mono.WebBrowser | grep -q "Mono.WebBrowser"
++ then
++ AC_MSG_RESULT([yes])
++ enable_monowebbrowser=yes
++ MONOWEBBROWSER_LIBS=-r:Mono.WebBrowser
++ else
++ AC_MSG_RESULT([no])
++ enable_monowebbrowser=no
++ fi
++ fi
+ fi
+-MONOWEBBROWSER_LIBS=-r:Mono.WebBrowser
++
+ AM_CONDITIONAL(ENABLE_MONOWEBBROWSER, test "x$enable_monowebbrowser" = "xyes")
+
+ if test "x$enable_gtkhtml$enable_gecko$enable_monowebbrowser$enable_webkit" = "xnononono" ; then
+ AC_MSG_ERROR([no HTML display found. You need either gtkhtml, gecko, WebKit or Mono.WebBrowser])
+ fi
diff --git a/dev-util/mono-tools/mono-tools-2.4.2.ebuild b/dev-util/mono-tools/mono-tools-2.4.2-r1.ebuild
index 0e7c390f050b..19942c6ebf21 100644
--- a/dev-util/mono-tools/mono-tools-2.4.2.ebuild
+++ b/dev-util/mono-tools/mono-tools-2.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-2.4.2.ebuild,v 1.1 2009/06/30 06:02:08 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-2.4.2-r1.ebuild,v 1.1 2009/09/02 14:05:04 loki_val Exp $
EAPI=2
@@ -12,27 +12,32 @@ HOMEPAGE="http://www.mono-project.com/"
LICENSE="GPL-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="webkit xulrunner"
+IUSE="webkit gtkhtml +xulrunner"
RDEPEND="=virtual/monodoc-${GO_MONO_REL_PV}*
>=dev-dotnet/gtk-sharp-2.12.6
>=dev-dotnet/glade-sharp-2.12.6
>=dev-dotnet/gconf-sharp-2
- >=dev-dotnet/gtkhtml-sharp-2
- webkit? ( dev-dotnet/webkit-sharp )
- xulrunner? (
- >=dev-dotnet/gecko-sharp-0.13
- =dev-dotnet/gluezilla-${PV}
- )"
+ gtkhtml? ( >=dev-dotnet/gtkhtml-sharp-2.24.0 )
+ webkit? ( >=dev-dotnet/webkit-sharp-0.2-r1 )
+ xulrunner? ( =dev-dotnet/gluezilla-${PV} )
+ "
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/pkgconfig-0.19"
-PATCHES=( "${FILESDIR}/${PN}-2.0-html-renderer-fixes.patch" )
+PATCHES=( "${FILESDIR}/${PN}-2.4-html-renderer-fixes.patch" )
#Fails parallel make.
MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if ! use webkit && ! use gtkhtml && ! use xulrunner
+ then
+ die "You must USE either webkit, gtkhtml or xulrunner"
+ fi
+}
+
src_prepare() {
go-mono_src_prepare
eautoreconf
@@ -40,9 +45,10 @@ src_prepare() {
src_configure() {
econf --disable-dependency-tracking \
- --enable-gtkhtml \
- $(use_enable xulrunner mozilla) \
+ --disable-gecko \
+ $(use_enable gtkhtml) \
$(use_enable webkit) \
+ $(use_enable xulrunner monowebbrowser) \
|| die "configure failed"
}
diff --git a/dev-util/mono-tools/mono-tools-2.4.9999.ebuild b/dev-util/mono-tools/mono-tools-2.4.9999.ebuild
index 859d6e8aaa2f..0324254e73c8 100644
--- a/dev-util/mono-tools/mono-tools-2.4.9999.ebuild
+++ b/dev-util/mono-tools/mono-tools-2.4.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-2.4.9999.ebuild,v 1.3 2009/06/09 21:19:35 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-2.4.9999.ebuild,v 1.4 2009/09/02 14:05:04 loki_val Exp $
EAPI=2
@@ -12,27 +12,32 @@ HOMEPAGE="http://www.mono-project.com/"
LICENSE="GPL-2 MIT"
SLOT="0"
KEYWORDS=""
-IUSE="webkit xulrunner"
+IUSE="webkit gtkhtml +xulrunner"
RDEPEND="=virtual/monodoc-${GO_MONO_REL_PV}*
>=dev-dotnet/gtk-sharp-2.12.6
>=dev-dotnet/glade-sharp-2.12.6
>=dev-dotnet/gconf-sharp-2
- >=dev-dotnet/gtkhtml-sharp-2
- webkit? ( dev-dotnet/webkit-sharp )
- xulrunner? (
- >=dev-dotnet/gecko-sharp-0.13
- =dev-dotnet/gluezilla-${PV}
- )"
+ gtkhtml? ( >=dev-dotnet/gtkhtml-sharp-2.24.0 )
+ webkit? ( >=dev-dotnet/webkit-sharp-0.2-r1 )
+ xulrunner? ( =dev-dotnet/gluezilla-${PV} )
+ "
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/pkgconfig-0.19"
-PATCHES=( "${FILESDIR}/${PN}-2.0-html-renderer-fixes.patch" )
+PATCHES=( "${FILESDIR}/${PN}-2.4-html-renderer-fixes.patch" )
#Fails parallel make.
MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if ! use webkit && ! use gtkhtml && ! use xulrunner
+ then
+ die "You must USE either webkit, gtkhtml or xulrunner"
+ fi
+}
+
src_prepare() {
glib-gettextize --force --copy || die "glib-gettextize --force --copy failed"
go-mono_src_prepare
@@ -40,9 +45,10 @@ src_prepare() {
src_configure() {
econf --disable-dependency-tracking \
- --enable-gtkhtml \
- $(use_enable xulrunner mozilla) \
+ --disable-gecko \
+ $(use_enable gtkhtml) \
$(use_enable webkit) \
+ $(use_enable xulrunner monowebbrowser) \
|| die "configure failed"
}
diff --git a/dev-util/mono-tools/mono-tools-9999.ebuild b/dev-util/mono-tools/mono-tools-9999.ebuild
index 2f3cbd4dcb0d..6459e6c809f6 100644
--- a/dev-util/mono-tools/mono-tools-9999.ebuild
+++ b/dev-util/mono-tools/mono-tools-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-9999.ebuild,v 1.3 2009/06/09 21:19:35 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-9999.ebuild,v 1.4 2009/09/02 14:05:04 loki_val Exp $
EAPI=2
@@ -12,27 +12,32 @@ HOMEPAGE="http://www.mono-project.com/"
LICENSE="GPL-2 MIT"
SLOT="0"
KEYWORDS=""
-IUSE="webkit xulrunner"
+IUSE="webkit gtkhtml +xulrunner"
RDEPEND="=virtual/monodoc-${GO_MONO_REL_PV}*
>=dev-dotnet/gtk-sharp-2.12.6
>=dev-dotnet/glade-sharp-2.12.6
>=dev-dotnet/gconf-sharp-2
- >=dev-dotnet/gtkhtml-sharp-2
- webkit? ( dev-dotnet/webkit-sharp )
- xulrunner? (
- >=dev-dotnet/gecko-sharp-0.13
- =dev-dotnet/gluezilla-${PV}
- )"
+ gtkhtml? ( >=dev-dotnet/gtkhtml-sharp-2.24.0 )
+ webkit? ( >=dev-dotnet/webkit-sharp-0.2-r1 )
+ xulrunner? ( =dev-dotnet/gluezilla-${PV} )
+ "
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/pkgconfig-0.19"
-PATCHES=( "${FILESDIR}/${PN}-2.0-html-renderer-fixes.patch" )
+PATCHES=( "${FILESDIR}/${PN}-2.4-html-renderer-fixes.patch" )
#Fails parallel make.
MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if ! use webkit && ! use gtkhtml && ! use xulrunner
+ then
+ die "You must USE either webkit, gtkhtml or xulrunner"
+ fi
+}
+
src_prepare() {
glib-gettextize --force --copy || die "glib-gettextize --force --copy failed"
go-mono_src_prepare
@@ -40,9 +45,10 @@ src_prepare() {
src_configure() {
econf --disable-dependency-tracking \
- --enable-gtkhtml \
- $(use_enable xulrunner mozilla) \
+ --disable-gecko \
+ $(use_enable gtkhtml) \
$(use_enable webkit) \
+ $(use_enable xulrunner monowebbrowser) \
|| die "configure failed"
}