summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cscope/ChangeLog8
-rw-r--r--dev-util/cscope/cscope-15.5-r6.ebuild79
-rw-r--r--dev-util/cscope/files/digest-cscope-15.5-r32
-rw-r--r--dev-util/cscope/files/digest-cscope-15.5-r66
4 files changed, 94 insertions, 1 deletions
diff --git a/dev-util/cscope/ChangeLog b/dev-util/cscope/ChangeLog
index 0eefd525dd35..0129d6a48b1f 100644
--- a/dev-util/cscope/ChangeLog
+++ b/dev-util/cscope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cscope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.57 2006/04/08 21:19:56 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.58 2006/06/01 04:04:02 mkennedy Exp $
+
+*cscope-15.5-r6 (01 Jun 2006)
+
+ 01 Jun 2006; <mkennedy@gentoo.org> +cscope-15.5-r6.ebuild:
+ Fix for http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2541;
+ Resolves Bug #133829.
*cscope-15.5-r5 (08 Apr 2006)
diff --git a/dev-util/cscope/cscope-15.5-r6.ebuild b/dev-util/cscope/cscope-15.5-r6.ebuild
new file mode 100644
index 000000000000..99d151229909
--- /dev/null
+++ b/dev-util/cscope/cscope-15.5-r6.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.5-r6.ebuild,v 1.1 2006/06/01 04:04:02 mkennedy Exp $
+
+inherit gnuconfig elisp-common eutils
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz
+ mirror://gentoo/${P}-debian-security.patch.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50xcscope-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+
+ # ~30 buffer overflows fix: Gentoo Bug #133829, patch developed by
+ # the Debian Security Team (thanks to those guys), CVE-2004-2541,
+ # Moritz Muehlenhoff. The Debian patch also includes the tempfile
+ # fix (previously ${PN}-${PV}-tempfile.patch)
+ epatch ${P}-debian-security.patch
+
+ cd ${S}
+
+ # build progress patch (bug 94150)
+ epatch ${FILESDIR}/${PN}-${PV}-prog-info.patch
+
+ # BSD memset test (Bug #129128)
+ epatch ${FILESDIR}/${P}-memset.patch
+}
+
+src_compile() {
+ gnuconfig_update
+
+ # This fix is no longer needed as of cscope-15.5 which now should
+ # work with bison directly. (04 Feb 2004 agriffis)
+ #sed -i -e "s:={:{:" src/egrep.y
+
+ econf || die
+ make clean || die
+ emake || die
+
+ if use emacs ; then
+ cd ${S}/contrib/xcscope || die
+ elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ einstall || die
+ dodoc NEWS AUTHORS TODO ChangeLog INSTALL README* || die
+
+ if use emacs ; then
+ cd ${S}/contrib/xcscope || die
+ elisp-install xcscope *.el *.elc || die
+ elisp-site-file-install ${FILESDIR}/${SITEFILE} xcscope || die
+ dobin cscope-indexer || die
+ fi
+ cp -r ${S}/contrib/webcscope ${D}/usr/share/doc/${PF}/ || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cscope/files/digest-cscope-15.5-r3 b/dev-util/cscope/files/digest-cscope-15.5-r3
index 99cb973ef8e3..c58257c280e7 100644
--- a/dev-util/cscope/files/digest-cscope-15.5-r3
+++ b/dev-util/cscope/files/digest-cscope-15.5-r3
@@ -1 +1,3 @@
MD5 beb6032a301bb11524aec74bfb5e4840 cscope-15.5.tar.gz 243793
+RMD160 30623f07043abc90d76b384c407abe5813a8a716 cscope-15.5.tar.gz 243793
+SHA256 be49cda0a9d33add89cabe0dfcef436a2863a7b0b833767875e0b7a6e8b4c4d1 cscope-15.5.tar.gz 243793
diff --git a/dev-util/cscope/files/digest-cscope-15.5-r6 b/dev-util/cscope/files/digest-cscope-15.5-r6
new file mode 100644
index 000000000000..304161d3cc3b
--- /dev/null
+++ b/dev-util/cscope/files/digest-cscope-15.5-r6
@@ -0,0 +1,6 @@
+MD5 14f257516d824c439e60b43b89b3d6e9 cscope-15.5-debian-security.patch.gz 5765
+RMD160 2e7f7c768c51927a036e4aa8f8903c4511c9e025 cscope-15.5-debian-security.patch.gz 5765
+SHA256 17d3aa74fb9af5b085fa13eab2b96b3ed9cdeeebbe181144a72535da3c615352 cscope-15.5-debian-security.patch.gz 5765
+MD5 beb6032a301bb11524aec74bfb5e4840 cscope-15.5.tar.gz 243793
+RMD160 30623f07043abc90d76b384c407abe5813a8a716 cscope-15.5.tar.gz 243793
+SHA256 be49cda0a9d33add89cabe0dfcef436a2863a7b0b833767875e0b7a6e8b4c4d1 cscope-15.5.tar.gz 243793